Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Rpm Trouble
naza
post Feb 5 2004, 11:26 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 5-February 04
Member No.: 2,303



Hello am new to this board but have been using linux for a while but am still a "beginner"

anyway, i seem to have developed a problem with rpm

Whenever i run anything with rpm i get the following:

rpmdb: fatal region error detected; run recovery
error: db4 error(-30981) from dbenv->open: DB_RUNRECOVERY: Fatal error, run database recovery
error: cannot open Packages index using db3 - (-30982)
error: cannot open Packages database in /var/lib/rpm

Am running Mandrake 9.0

Any ideas?

Have searched these forums foir similar woes hand found a reference to "rpm -rebuilddb" but get same arror when i run this.

Any advice greatly appreciated

Thank you in advance


Naza
Go to the top of the page
 
+Quote Post
Jim
post Feb 5 2004, 12:40 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,280
Joined: 19-November 03
From: University of Minnesota- TC
Member No.: 1,828



Are you trying to run these rpms from the terminal or from the graphical windows? If you are running it from the terminal what prefixes are you using? ie rpm -??? package.rpm?


--------------------
--Jim Lester
jim@linuxhelp.net

Distro: Gentoo
System: AMD Athlon 3000+ XP 2.166 GHz
NVIDIA nForce2 IGP Chipset
1GB 333 MHz DDR SDRAM
NVIDIA nForce2 Dual Head 64 MB Graphics

Server Distro: CentOS
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 10:17 AM