Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Trashed Grub With Windoze!
post Nov 22 2002, 11:20 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 22-November 02
Member No.: 179

Hello all

Well, yesterday started out as such a happy day. ATI released new Linux drivers that enabled OpenGL on the Radeon 8500. Finally, I could at least try and get a little further with UT2003. glxgears used to report 200-230fps, and it went up to 2500+fps!!! Wonderful! So, pop the UT2003 CD in and start the install. Hmmm, 2.5GB, and I don't have it. No worries! I'll boot back into Win2K and delete my M: drive, used it as a scratch drive for vid capture. So, boot in, do that, reboot and, guess what


Hmm. No idea, pull out the notebook, Google away, and get so far as to get grub reinstalled. Grub comes up now, the splash screen is gone, I cannot boot Linux, but of all things, Win2K boots. Here is the error I get booting Linux

Booting Redhat Linux 2.4.18-17.8.0

root (hd1,2)
Filesystem type unknown, partition type 0xf
kernel /vmlinuz-2.4.18-17.8.0 ro root=LABEL=/

Error 17: Cannot mount selected partition

I can boot with the CD and get into rescue mode and get my system mounted under /mnt/sysimage (do I have a fully functional system after I do the chroot? Seems mostly, haven't tried X tho). Everything looks like it's there. fdisk -l reports

Device Boot ID System
/dev/hda1 * c Win95 FAT32

Device Boot ID System
/dev/hdb1 7 NTFS
/dev/hdb2 * 83 Linux
/dev/hdb3 f Win95 Extd
/dev/hdb5 83 Linux
/dev/hdb6 82 Linux swap

and here is grub.conf

title Redhat 2.4.18-17.8.0
root (hd1,2)
kernel /vmlinuz-2.4.18-17.8.0 ro root=LABEL=/
initrd /initrd-2.4.18-17.8.0.img

title DOS
rootnoverify (hd0,0)

I actually also have another kernel option from the original install, but I didn't include to try and make this shorter. Suffice to say it does the same thing.

I'm pretty sure I can get this back, just not exactly sure how. I don't have a boot disk because I don't have a floppy. I guess I could put one in, but I think I can get this without it.

Any help muchly appreciated.
Go to the top of the page
+Quote Post
post Nov 22 2002, 02:35 PM
Post #2

RMS is my Hero

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5

possibly when you deleted your M:
it changed the configuration of structure of the hard drive
and re-arranged the numbering of the partitions
and might have caused grub to be looking for the correct partition
yet it was numbered differently since you deleted your M: in

its only a guess....might not be the reason ...but its a possibility


Chris W.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 21st March 2018 - 12:01 AM