Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> My Box Desn't Turn Off
LinuxMerlin
post Nov 22 2002, 09:43 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 22-November 02
Member No.: 178



wink.gif
I have been using Mandrake for several month now. When the 9.0 version appeared I switched and since then I haven't had any problem. But yesterday when I wanted to switch my box off, the computer rebooted instead of halting. I have tried "shutdown -h" as root and I have tried the userfriendly KDE method, but nothing. Has somebody a clue where and how I can adjust the setting?

Greetz
Merlin
Go to the top of the page
 
+Quote Post
Hemant
post Nov 26 2002, 07:23 AM
Post #2


RMS is my Hero
******

Group: Support Specialist
Posts: 782
Joined: 6-October 02
From: Trichy,INDIA
Member No.: 29



it appears that u have deleted some files that r required for halting ur pc.
have u tried
halt
and shutdown from gnome menu.


--------------------
Hemant Kumar
user posted image
hemant@linuxhelp.net
Go to the top of the page
 
+Quote Post
Corey
post Nov 26 2002, 03:54 PM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



Save everything you're doing, and from the command line issue the command (as root) "init 0" (the number zero). If you're system does not shutdown and halt, then you have some serious problems. To learn more about this, type "man runlevel".


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post
bensode
post Nov 27 2002, 04:52 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 15
Joined: 18-November 02
Member No.: 164



Your init could be screwed up. At the LILO prompt, try forcing single user mode (root required) by entering "linux single" (without the quotes) at the LILO prompt at boot. Once you enter single user mode, try to run init 0 and check for power-off. Sometimes hardware (ram, pci cards, bad mobo) can really screwup.

If as root "init 0" does not halt the system it could be something as trivial as a firmware issue in a piece of hardware. I have experienced with Compaq Deskpro 2000 series and the "a" chip Intel Pro100 nic's a powerdown issue. There was a flaw in the Intel chipset on the Pro100 that forced a remote boot command to the bios, thus preventing it to shutdown and always "reboot". This was documented on the Intel site and they offered to replace the card if you weren't comfortable with burning a new eprom =)

So ... if you are positive that it's not a system problem, check all of your hardware's firmware and see if there are any known bugs (such as mine above).

Morbid_Angel
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 09:23 PM