Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Changing Active Irq In /proc/isapnp
johnk
post Jan 16 2004, 11:19 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 28-December 03
Member No.: 2,024



Hi,

I'm trying to change the I/O and IRQ settings for my isa nic. It looks like its getting assigned IRQ 10 at boot:
CODE
isapnp: Scanning for PnP cards...
isapnp: Card 'SMC EtherEZ (8416)'
isapnp: 1 Plug & Play card detected total
smc-ultra.c: Presently autoprobing (not recommended) for a single card.
smc-ultra.c: ISAPnP reports SMC EtherEZ (8416) at i/o 0x240, irq 10.
smc-ultra.c:v2.02 2/3/98 Donald Becker (becker@cesdis.gsfc.nasa.gov)
eth0: SMC EtherEZ at 0x240, 00 E0 29 16 9F E2,assigned  IRQ 10 programmed-I/O mode.



Here's what my /proc/isapnp file currently looks like:

CODE
[root@localhost root]# cat /proc/isapnp
Card 1 'SMC8416:SMC EtherEZ (8416)' PnP version 1.0 Product version 1.0
 Logical device 0 'SMC8416:Unknown'
   Supported registers 0x2
   Device is active
   Active port 0x240
   Active IRQ 10 [0x2]
   Active DMA 0,0
   Resources 0
     Priority preferred
     Port 0x240-0x3e0, align 0x1f, size 0x20, 10-bit address decoding
     IRQ 3,5,7,2/9,10,11 High-Edge


I've tried adding options smc-ultra irq=3 to the /etc/modules.conf file, and then rebooting, doing an ifdown eth0 and ifup eth0 but no matter what I do it always says Active IRQ 10 in /proc/isapnp. If I try changing the device IRQ through the redhat networking option, it just adds like options line to modules.conf like I had it, but the active irq is still listed as 10. I've also tried unchecking the 'activate at boot' option, and then doing a /etc/init.d/network restart but it still shows the same thing. I'm trying to make the device use IRQ 3 and Input/Output range 0240 - 025F. Any suggestions as to how I could go about doing this?

Thanks,
John
Go to the top of the page
 
+Quote Post
hughesjr
post Jan 17 2004, 06:48 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I don't think you can change the IRQ that is assigned to the Card via linux ... that is done by the OS at bootup. You will need to use either jumpers on the card... a software program from the manufacturer to make the card boot with a different IRQ... or remove the IRQ 10 from PNP assignement in the bios to have a different IRQ assigned to the card.

The switches you are using on the driver just override the default settings if the card is assigned (by jumper or BIOS) to a different IRQ than is detected by the driver ... it doesn't affect what IRQ the OS assigns to the card.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 03:38 PM