Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Eth0 Dissapears From Ifconfig After Dhcpcd
johnk
post Jan 13 2004, 02:36 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 28-December 03
Member No.: 2,024



I managed to get my network card (SMC EtherEZ (8416)) to show up in ifconfig under eth0 by doing a modprobe smc-ultra, and it seemed to go well. However, when I do a dhcpcd eth0, there is a pause, and then it returns me the prompt without a response. After this, the internet still does not work. When I go to check ifconfig again, eth0 is not there anymore.

Here is some information I obtained that may be useful:

ifconfig - http://www.angelfire.com/bug/hardware/2
lsmod - http://www.angelfire.com/bug/hardware/3

I'm connecting to the internet through a cable modem and comcast@home is my ISP. When I installed the card in windows, it loaded the drivers and I didn't have to assign an IP address or set up anything so it seems like DHCP is the right choice. Is there something I'm missing? If it matters, I'm using slackware 9.1. I've tried netconfig and this does not help.

Here is the information shown at boot (I commented out the right line in /etc/rc.d/rc.modules/etc/modules.conf):

isapnp: Scanning for PnP cards...
isapnp: Card 'SMC EtherEZ (8416)'
isapnp: 1 Plug & Play card detected total
smc-ultra.c: Presently autoprobing (not recommended) for a single card.
smc-ultra.c: ISAPnP reports SMC EtherEZ (8416) at i/o 0x240, irq 10.
smc-ultra.c:v2.02 2/3/98 Donald Becker (becker@cesdis.gsfc.nasa.gov)
eth0: SMC EtherEZ at 0x240, 00 E0 29 16 9F E2,assigned IRQ 10 programmed-I/O mode.
Go to the top of the page
 
+Quote Post
johnk
post Jan 13 2004, 04:37 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 28-December 03
Member No.: 2,024



I've tried setting up the info by typing in my IP address etc, and after I do this I am able to ping myself but nothing else. I wrote down the information from winipcfg in win98, and I've tried putting that in the manual setup. Any suggestions?
Go to the top of the page
 
+Quote Post
hughesjr
post Jan 13 2004, 06:36 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



try editing the file /etc/modules.conf and adding this line:

alias eth0 smc-ultra

then saving /etc/modules.conf...

Then edit the file /etc/rc.d/rc.inet1.conf and make sure the only thing in there that is not set to ="" (which is blank) is these 2 lines:

USE_DHCP[0]="yes"
DEBUG_ETH_UP="no"


everything else in the file should be like this (where xxxxxx is the variable name):

xxxxxx=""

reboot and the eth0 should start ....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
johnk
post Jan 13 2004, 08:17 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 28-December 03
Member No.: 2,024



I added this, and my system was experiencing the same behavior. Thinking I may have modified something I shouldn't have, I decided to reinstall redhat 9.0 since my internet connection worked with it on the first install and I was willing to settle. Now, I started over from a fresh install of Red Hat 9.0 and the internet does not work there, either. It was working the first time I installed it a little while ago but now it doesn't work. My ISP (comcast@home) conveniently does not offer support for linux, and since my connection is working in windows there is nothing they can help me with. Based on this, I don't think it's the settings that are incorrect but I don't know what is or what I can do about it. Comcast asked me if I was using a router because there was some type of conflict and I'm thinking that may have something to do with it but the support agent did not know anything of the nature. I booted up red hat while I was on the phone with support and they said I was pinging okay, but the connection does not work and it tells me failed when bringing up eth0. I asked what to put in for DNS server etc, but the lady told me it should get that by itself. Does anybody have a suggestion - this problem is quite frustrating. Again I'm just using a cable modem, with one computer. No special networking options right now. What could keep my DHCP from working in all distros of linux (but not windows apparently) and how can I fix it?
Go to the top of the page
 
+Quote Post
hughesjr
post Jan 13 2004, 09:13 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



After you login (as root) in redhat 9, issue this command:

/etc/init.d/network restart

try:

modprobe smc-ultra

if that works add the line:

alias eth0 smc-ultra

to /etc/modules.conf

------------------
BTW ... ISA cards are hard to setup ... can this PC use a PCI network card?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
johnk
post Jan 15 2004, 12:22 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 28-December 03
Member No.: 2,024



alias eth0 smc-ultra was already in /etc/modules.conf. I tried the network restart, but got the same behavior as I did at boot. I tried changing the irq (through redhat settings) but that didn't help. I tried manually setting the addresses as I got from winipcfg through gnome, and when I did the Redhat boot gave me an OK on bringing up eth0, but the internet still did not work. As for PCI cards, I've tried 3: a dlink card, with non-functional drivers, and 2 dysfunction linksys cards (while technical support ignored my email even with their 24 hour response promise rule). I suppose I could look around some more and try to find a 3com card and see how that works, but as for my ISA card it seems as if I'm pretty much up a creek, huh?

John
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 09:57 AM