Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Strange Display Size/resolution Problem, Some apps display as tho on a big screen
gfox
post Dec 24 2003, 10:08 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 24-December 03
Member No.: 2,018



I have Redhat 9 installed on a dual boot laptop (Dell Latitude C800). Some applications behave bizarrely, though -- the obvious feature is that they display as though the monitor was a bigscreen tv instead of a laptop. In other words, fonts are gigantic, single buttons take more than the whole screen, etc.

This is the case for the OpenOffice suite and for some KDE apps. I've fooled with this for a few days and have to admit that I'm baffled, especially since other applications work fine. My guess is that either the font server or the X server are configured wrong, but there's nothing in the config files (appended) that (to me) is obviously wrong.

Any suggestions?

Gordon

Here's my /usr/X11R6/lib/X11/fs/config file:
# Default font server configuration file for Red Hat Linux
#

# allow a max of 10 clients to connect to this font server
client-limit = 10

# when a font server reaches its limit, start up a new one
clone-self = on

# alternate font servers for clients to use
#alternate-servers = foo:7101,bar:7102

# where to look for fonts
#
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/misc,
/usr/X11R6/lib/X11/fonts/Type1,
/usr/X11R6/lib/X11/fonts/Speedo,
/usr/X11R6/lib/X11/fonts/TTF,
/usr/share/fonts/default/Type1,
,
/usr/share/AbiSuite/fonts,
/usr/share/fonts/ja/TrueType
# /usr/X11R6/lib/X11/fonts/cyrillic,
# in 12 points, decipoints
default-point-size = 120

# 100 x 100 and 75 x 75
default-resolutions = 75,75,100,100

# use lazy loading on 16 bit (usually Asian) fonts
deferglyphs = 16

# how to log errors
use-syslog = on

# don't listen to TCP ports by default for security reasons
no-listen = tcp
##############################################################

and here's my /etc/X11/XF86Config file
# XFree86 4 configuration created by redhat-config-xfree86

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "DevInputMice" "AlwaysCore"
EndSection

Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the
# file minus the extension (like ".txt" or ".db"). There is normally
# no need to change the default.
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Red Hat 6.0 and later now use a font server independent of
# the X server to render fonts.
RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
Load "dri"
EndSection

Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
# Option "Xleds" "1 2 3"
# To disable the XKEYBOARD extension, uncomment XkbDisable.
# Option "XkbDisable"
# To customise the XKB settings to suit your keyboard, modify the
# lines below (which are the defaults). For example, for a non-U.S.
# keyboard, you will probably want to use:
# Option "XkbModel" "pc102"
# If you have a US Microsoft Natural keyboard, you can use:
# Option "XkbModel" "microsoft"
#
# Then to change the language, change the Layout setting.
# For example, a german layout can be obtained with:
# Option "XkbLayout" "de"
# or:
# Option "XkbLayout" "de"
# Option "XkbVariant" "nodeadkeys"
#
# If you'd like to switch the positions of your capslock and
# control keys, use:
# Option "XkbOptions" "ctrl:swapcaps"
# Or if you just want both to be control, use:
# Option "XkbOptions" "ctrl:nocaps"
#
Identifier "Keyboard0"
Driver "keyboard"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "yes"
EndSection

Section "InputDevice"

# If the normal CorePointer mouse is not a USB mouse then
# this input device can be used in AlwaysCore mode to let you
# also use USB mice at the same time.
Identifier "DevInputMice"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "no"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "Dell 1600x1200 Laptop Display Panel"
DisplaySize 12 9
HorizSync 31.5 - 90.0
VertRefresh 59.0 - 85.0
Option "dpms"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "r128"
VendorName "Videocard vendor"
BoardName "ATI Rage Mobility M4 AGP"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1400x1050" "1280x1024" "1280x960" "1152x864" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "DRI"
Group 0
Mode 0666
EndSection
Go to the top of the page
 
+Quote Post
gfox
post Dec 24 2003, 06:46 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 24-December 03
Member No.: 2,018



I fixed the OpenOffice problem by uninstalling and then reinstalling with a new build (trying to reinstall the same build led to an unreadable install screen . . . ).

The other apps continue to have this problem. E.g., kdehelpcenter displays help in an unreadable fashion -- enormous font sizes. Nothing I do succeeds in resetting the fonts. Similarly, the Crossover Office install fails because the install screen is unreadable.

Cheers,
Gordon
Go to the top of the page
 
+Quote Post
gfox
post Dec 25 2003, 04:17 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 24-December 03
Member No.: 2,018



Problem solved!

It was the "Display size 12 9" line in my XF86Config file. A look at the XF86 log said that the server was interpreting these numbers as being in millimeters (though the RedHat utility I used to set the display asked me in *inches*). Why other applications worked, I don't know, but commenting that line out and rebooting left me with an X server that works fine for all the apps now.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 05:27 AM