Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Samba Share Permissions
fredgrimple
post Dec 23 2003, 07:11 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 23-December 03
Member No.: 2,012



Hello, I hope there's someone who can help. I've installed Samba on a Mandrake 9.2 box. I've created users and computer accounts for client access. I've created directories to share and configured them in the smb.conf file. Everything works great, users can join the samba domain and access shares. But after a while - and the time varies - the folders are no longer accessible. When I look on the samba box, the permissions I had set on the folders are gone. For example, I created an Accounts folder in /home I chmod 0770 /home/Accounts to give it rwxrwx--- permissions. After some time if I ls -l the directories under /home the permissions on every folder is rwx------.

Anyone have any ideas why?

Thanks in advance

Fred Grimple
Go to the top of the page
 
+Quote Post
hughesjr
post Dec 25 2003, 09:23 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



That seems very wierd ...

I would look in the crontab for root (crontab -e) ... if you don't have a crontab, look at all files in /etc/cron.xxx:

some pc's have a /etc/crontab and directories like

/etc/cron.daily
/etc/cron.hourly
/etc/cron.monthly


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
fredgrimple
post Jan 12 2004, 11:57 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 23-December 03
Member No.: 2,012



I figured it out. MSEC changes the permissions by default depending on the level you choose. If you enter msec 4, the security level is raised to 4 with it's associated permssions. To set manual permissions on some folders, you have to create a perm.local file in /etc/security/msec/ In this file list the folders you want to set permissions for, along with the user and group ownership, and the permissions you need. So if sharing the public folder in home write in perm.local:
/home/public/ root.usergroup 0776

Then msec can keep doing it's thing and the public folder will not change.
Go to the top of the page
 
+Quote Post
hughesjr
post Jan 12 2004, 08:55 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I always turn off the Mandrake (or any other distro's) default firewall / security and download a good iptables firewall script ... so I would have never figured that out biggrin.gif

Thanks for posting the answer ... It will help others who search in the future!


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 04:27 AM