Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Nfs Export On Redhat 8.0
nifflerX
post Dec 17 2003, 10:19 AM
Post #1


./configure
***

Group: Members
Posts: 76
Joined: 4-November 03
Member No.: 1,751



Hi,

I'm trying to export a directory (via NFS) from a box running redhat 8.0 to another box running redhat 8.0. Both boxes are currently receiving exported directories from two other machines, both running rehat 7.1. The two 8.0 boxes mount the exported directories using autofs. All the machines are connected via a LAN ethernet. I would like to use the same kind (autofs) of mount between the two 8.0 boxes. Right now the server (8.0 box) has nfs, nfslock, and portmap turned on, while the client (second 8.0 box) has only nfslock and portmap turned on. I've tried to configure all the necessary files, here's what they look like:

/etc/exports on the server:

/home/updates 128.135.92.0/255.255.255.0(no_root_squash,ro,async)

However, the strange thing about this is that when I run exportfs -arv, /proc/fs/nfs/exports stays empty (except for the commented out lines that are always there), but on many of the websites detailing how to set up an NFS server, this file should be changed to match what is in /etc/exports. I believe this could be a problem, but have no idea how to fix it.

Anyway the setup on the client is as follows:

/etc/auto.updates:
updates -ro,hard,intr,bg,rsize=16384,wsize=16384,tcp,notco,actimeo=90 128.135.92.48:/home/updates

and /etc/auto.master

# $Id: auto.master,v 1.2 1997/10/06 21:52:03 hpa Exp $
# Sample auto.master file
# Format of this file:
# mountpoint map options
# For details of the format look at autofs(8).
# /misc /etc/auto.misc --timeout=60
/nfs/raidzone /etc/auto.raidzone --timeout=60
/nfs/updates /etc/auto.updates --timeout=60

I've tried re-exporting everything, as well as restarting the nfs services on both the client and the server but still I can't get the client to mount the, theorectially, exported directory. Also, I have made sure that /nfs/updates does exist locally on the client. I've read places that turning the firewall and ipchains off will help this situation, however that is not an option for me, I need to keep those protection devices in place. It might be possible for me to take them down for a very short bit, but they must stay on in general. Thanks so much, in advance.


-nifflerX
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 07:10 AM