Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Sendmail Problems
Joey
post Dec 15 2003, 01:24 PM
Post #1


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Hi All,

As of this morning I'm having issues with sendmail. I'm seeing quite a few of the following when I run a 'ps aux' on the system:

3496 ? S 0:00 sendmail: hBFHwgmi003496 mxpool22.ebay.com [66.135.197.28]: DATA
3670 ? S 0:00 sendmail: hBFI44mi003670 fr2.webmaillogin.com [216.40.35.66]: DATA
3746 ? S 0:00 sendmail: hBFI8Nmi003746 [204.101.240.3]: DATA
4188 ? S 0:00 sendmail: hBFIJ4mi004188 fr2.webmaillogin.com [216.40.35.66]: DATA

They don't seem to be disappearing. The only thing that has really changed on my end is the installation of a wireless router. I can send and receive mail normally, I just have no idea why those ones listed above are getting stuck. Has anyone seen this before?

Thanks
Go to the top of the page
 
+Quote Post
Joey
post Dec 15 2003, 11:10 PM
Post #2


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Further to this, I'm now seeing the following in my maillog

Dec 15 22:45:21 linuxhelp sendmail[4332]: hBG1jF17004332: timeout waiting for input from [203.155.9.146] during message collect

Dec 15 22:45:21 linuxhelp sendmail[4332]: hBG1jF17004332: from=<info8@bvimailbox.com>, size=36, class=0, nrcpts=1, msgid=<200312160145.hBG1jF17004332@linuxhelp.ca>, proto=SMTP, daemon=MTA, relay=[203.155.9.146]

Dec 15 22:45:21 linuxhelp sendmail[4332]: hBG1jF17004332: to=<joey@linuxhelp.ca>, delay=02:00:00, pri=30036, stat=timeout waiting for input during message collect
Go to the top of the page
 
+Quote Post
hughesjr
post Dec 16 2003, 08:31 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I haven't seen anything like this before....

can you remove the wireless router (replaced by the old solution) and see if the problem goes away?

Sometimes a firmware upgrade in the routers (to the latest version) fixes routing problems...

It could also be that the router only handles so many connections through it ... and if it is full it waits (therefore causing timeouts). I know that WinRoute Pro (a software firewall for win2003) limits connections per host behind the firewall and has a max limit for all hosts...that i had to increase to run a mail, a www and a dns behind it.

Check to see if there is a way to increase the number of connections per host on the firewall/router.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Joey
post Dec 16 2003, 08:38 AM
Post #4


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



The router has the latest version of the firmware installed. I'm going to revert the network later this week if I cannot figure it out (it's just a huge pain in the ass to do it again).

For some reason the size is coming up as zero:

Dec 16 08:31:23 linuxhelp sendmail[8746]: hBGDVC3V008746: lost input channel from 66-108-179-82.nyc.rr.com [66.108.179.82] to MTA after rcpt

Dec 16 08:31:23 linuxhelp sendmail[8746]: hBGDVC3V008746: from=<dgpbzf11@yahoo.com>, size=0, class=0, nrcpts=0, proto=SMTP, daemon=MTA, relay=66-108-179-82.nyc.rr.com [66.108.179.82]

I believe this issue is being caused by the router or some weird DNS issue. I don't think the connection limit is in place because a buddy of mine mailbombed me yesterday to test it and all the messages came through. It's just from certain places that the mail is getting stuck.

Here's one that always gets stuck:

Dec 16 07:57:40 linuxhelp sendmail[8392]: hBGBvX3V008392: timeout waiting for input from [204.101.240.3] during message collect

Dec 16 07:57:40 linuxhelp sendmail[8392]: hBGBvX3V008392: from=<mpark@dlink.ca>, size=0, class=0, nrcpts=1, msgid=<200312161157.hBGBvX3V008392@linuxhelp.ca>, proto=ESMTP, daemon=MTA, relay=[204.101.240.3]

Dec 16 07:57:40 linuxhelp sendmail[8392]: hBGBvX3V008392: to=<joey@linuxhelp.ca>, delay=01:00:01, pri=30000, stat=timeout waiting for input during message collect
Go to the top of the page
 
+Quote Post
Joey
post Dec 16 2003, 08:46 PM
Post #5


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Well, I think I figured it out.

I went through the router config looking for any type of settings that could affect this. Everything was set up properly, port 25 was open and forwarded to the mail server etc. I clicked onto the WAN configuration page and noticed that the MTU was set to 1492. All my NIC cards default to 1500... I tried changing the MTU on the router to 1500 however according to D-Link, 1500 is invalid. So I changed the MTU on the NIC on the mail server to 1492, restarted sendmail and the problem has gone away....

I'm going to email D-Link tomorrow about this. I'm just glad I can get all my mail again smile.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Dec 17 2003, 12:03 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



That is very strange ... are you connected via PPPOE to the internet (1492 is the max mtu for PPPOE connections)?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Joey
post Dec 17 2003, 08:49 AM
Post #7


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



That is correct.
Go to the top of the page
 
+Quote Post
hughesjr
post Dec 17 2003, 10:39 AM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



It's been 4 years since I used PPPOE, but when I did use it, I did have to set the MTU on the firewall outside ethernet card to 1492 ... but the inside ethernet card on the firewall and all the internal PC's remained at 1500 for MTU.

I don't recall any porblems with that setup ... although my firewalls have always been a PC with a software Firewall/NAT (either Linux, BSD, or Win2K/2K3 server)...and not the Firewall / NAT type DSL/CABLE routers. Those devices do look pretty convienent though and I have set them up for friends.

I would think this is a bug of some kind with the router ... although setting the MTU to 1492 isn't going to have a major impact on anything...and may actually help in connecting to other PPPOE places.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Joey
post Dec 17 2003, 10:47 AM
Post #9


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



It has a major impact on receiving mail when ethernet cards default to 1500 smile.gif

Anyways it's been a huge f'in pain in the ass but I'm glad it's working now.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 01:51 PM