Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Ide Dma Setup Problems, 2.4 mns 2load Suse9.0 w/serial raid
1Way
post Dec 3 2003, 02:15 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 3-December 03
Member No.: 1,894



Hello all, this is my first post on your forum, and it looks like a very well setup forum, I look forward to more from this site.

Iíve loaded Suse pro 9.0 CD roms a few times now (6 or so), after win XP, on a mobo w/silicon image serial raid controller with 2 seagate 80ís striped as one (raid 0). It found my hard drives as one raid drive just fine since I had my diskette that I made for winXP with the motherboard drivers for the serial and raid drivers on it. No problem there.(!)

The main (first) problem is that the hard drive seems to work very slow. It takes about 2.4 minuets to boot (and that is after the hardware boots)! Isnít that way too long to boot? How long is your boot? My XP loads in about 30 seconds or less.

I did some web surfing and found that apparently it has to do with the DMA mode being shut off, in one article/post he said turning on DMA made his hard drive up to 50 times faster. How do I benchmarch or speed check my hard drive throughput?

I have a brand new system, a

gigabyte 7nnxp, nvidia chipset w/AMD athlon 2500xp
1 gig of (overly fast) duel channel ram
onboard raid controller by silicon image (Sil 3112ACT144)
2 Ė 80 gig serial seagate hdís
ATI All In Wonder 9800pro 128 MB ddr (<-- very nice, BUT SUSE doesnít recognize it as such, something like a radeon 350 instead, AND it does NOT have 3D support, NO 3D I say, I canít even see a single 3D game, arrrggg.)

(Of course all works great in Win XP.) (duck)

Here is how I started seeing the problem.
There is a place within Suse, KDE 3.1, system, then YaST, then hardware, then hard drive ide DMA mode, then it lists my two hard drives and a CD Rom drive. You can select a single item, and then at the bottom would be a scroll selection box to choose which DMA mode you want! All 3 devices currant status all said they were set to no DMA. So I thought I could activate some DMA and fly (Right?), but so far, every selection Iíve tried ends up making bootup crash, and one selection even crashed right away. Aarrgggg.


So I am seeking these things.


1 - How do I properly enter into the command line a statement to shut off the DMA mode so that I can at least use the system again without reinstalling everything? Even in the boot window installer (lilo, I think?) it has a kernel option to turn off the DMA mode, it says enter the following:

ide=nodma

I enter that at the bottom where it says, boot options and a long blank box for entering text, and it makes no difference, when I watch the boot text lines it ends up setting the DMA mode which I last used within booted linux and then shortly after that all goes downhill very quickly.

Am I supposed to enter the kernel option the statement AFTER making a command, like the following?

Linux ide=nodma

2 - How do I find out which DMA my system can use without destruction from within? wink.gif So far Iíve tried using the following

- Ultra DMA 133
- Ultra DMA 16
- DMA on (default)

The last two at least let me continue to operate until I decided to shut down, AND it seemed to make hard drive tasks run faster too. But then booting crashes before I get through it. The first option, UDMA 133, it stopped everything immediately.

(Here are all the other selections)

No change
DMA off
DMA On (default mode)
DMA/16
Ultra DMA/16
Ultra DMA/33
Ultra DMA/66
Ultra DMA/100
Ultra DMA/133


I partitioned the two 80 gigers in the following way.

WinXP got 100 gig, which left an unpartioned area of the remainder (about 58 gigs) for Linux.

Suse automatically set up a separate partition of 1 gig or so (?), something about it being an active swap area or something like that. I get no problems with the installs every time despite having hardware serial raid 0, pretty cool, I felt really fortunate since I saw some online help forum posts with problems loading linux on a hardware raid setup.

So the main problems are the DMA mode (hard drive slowness) and not being able to correct a DMA setting so that I can boot safely without crashing. The installs always automatically end up setting the DMA mode on the hard drive to OFF, and so naturally the hard drive tasks are really slow. BUMMER.

Is there a good dependable way to test the hard drive speed?

Assistance is much appreciated!
Go to the top of the page
 
+Quote Post
hughesjr
post Dec 3 2003, 04:15 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



My P4 2.4 ghz machine takes 1min 15 seconds from the grub selection to GDM login screen ... and another 26 sec from login until the desktop is displayed.

Dual booting to XP, it takes 40 seconds to the login screen and 56 seconds until all the hardware detection is complete and I have full control of the desktop.

You have to remember that Linux does all hardware detection and setup takes place before you login ... while on XP it happens after you login.

Full time until all that is done and you are ready to type in a word processor is:

WindowsXP: 1:36
Linux 1:41

--------------------------------------------------------------------------------------------------------------------
I think your problem is the software RAID of the motherboard.

Do the command dmesg | less

look for IDE information....

Do you have 1 drive listed or 2?

If only 1 drive, then what does it say.

The command to set and test hard drive parameters is hdparm

the command:

hdparm -i /dev/hda

(use another drive for HDA if required).

hdparm -v /dev/hda

If you post the results of the hdparm -v and hdparm -i I will give you the commands to make adjustments to hard drive speed.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 18th October 2017 - 02:39 AM