Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Kernel Not Mounting Root Partition, Linux From Scratch partition
frodo44
post Dec 1 2003, 06:50 PM
Post #1


./configure
***

Group: Members
Posts: 95
Joined: 2-December 02
Member No.: 213



Hey, I just got finished building my shiny new LFS (linux from scratch) distro, and am ready to start it up, but I have something configured/compiled wrong to where the kernel doesn't want to mount my root partition. Here's the entirety of the error problems I get (starting from the first failure to the KERNEL PANIC message):

CODE
03:04 rw=0, want=2 limit=1
EXT3-FS: unable to read superblock
03:04 rw=0, want=2 limit=1
EXT2-FS: unable to read superblock
03:04 rw=0, want=2 limit=1
FAT: bogus logical sector size 0
attempt to access beyond the end of device
03:04 rw=0, want=33 limit=1
isofs_read_super:  bread failed, dev=03:04, iso_blknum=16,block=32
kmnd failed to exec /sbin/modprobe -s -k nls_iso8859-1, errno=2
attempt to access beyond end of device
03:04: rw=0,want=64,limit=1
sh-2006: reiserfs read_superblock: bread failed (dev 03:04,block 128, size 512)
sh-2021: reiserfs_read_super: can not find reiserfs on 03:04
Kernel Panic: VFS: unable to mount root fs on 03:04
spurious 8259A interrupt: IRQ7.


As much as I get from that is that the kernel's going through filesystems trying to find one that works (the partition that I'm trying to load (/dev/hdb2) is ext3), but it doesn't find anything that works. I think what it's doing is looking for the wrong partition, because as far as I know dev 03:04 is the equivalent of /dev/hda4, which doesn't exist on my hda drive. So I guess what's going on is that the kernel is looking for the wrong partition for root, and I don't know why. I anyone knows how to pass an option to the kernel telling it to look for /dev/hdb2 rather than /dev/hda4 for root, it would be very helpful. BTW, I'm using grub (newest version, I think). Thanks,

Eric


--------------------
Windows XP; Debian 3.0r2 (Woody)
---
Shuttle AK32 Mobo w/ Athlon XP 1700+ @ 266 FSB
GeForce 4 mx440 64mb
Turtle Beach Santa Cruz 5.1 Surround Sound
256 MB DDRAM
Seagate 80gb, Western Digital 40gb
---
weezle@charter.net
Go to the top of the page
 
+Quote Post
hughesjr
post Dec 1 2003, 08:37 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



in /boot/grub.conf, you should have an entry like this for LFS(this is from my redhat test machine):

CODE
title Red Hat Linux (2.6.0-0.test9.1.93)
       root (hd0,0)
       kernel /vmlinuz-2.6.0-0.test9.1.93 ro root=/dev/hda3
       initrd /initrd-2.6.0-0.test9.1.93.img


The root (hd0,0)<---{(hd0,0) is hda1 ... substitute your actual boot partition here} needs to be the location of the machines boot partition (not root partition) and you need to move the kernel (and initrd if you have one) to the boot partition ... then on the kernel line you need the path to the kernel (relative to the boot partition) ... and a root=/dev/hdb2


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 01:44 PM