Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> I Did Something Stupid ...., Can it be fixed?
monroe
post Nov 29 2003, 01:24 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-November 03
Member No.: 1,878



I did:
CODE
$chmod 777 /*

on a redhat 7.2 machine.
So basically, I set ALL files on my system to rwx. I was "clearing it out" .... moving needed files off it to another machine so I could format the HD and reinstall/upgrade. I kept running into file acces issues, so I just chmod'd everything to 777. Well, I rebooted the machine, and now it's hosed. I can't login as root. after logging in as a user and trying to su to root I get:
CODE
$su: root
Password: *****
su: Cannot set groups: Operation not permitted

Next, I tried using sudo to get root access:
CODE
$sudo bash
Sorry, sudo must be setuid root.


All I really need is ftp, so I tried to get the ftp server going as a regular user but that's no good either:
CODE
$ /sbin/proftpd
mydomain.com - unable to set daemon groups: Operation not permitted


Anything I can do to get rid of this problem? All I really need to do is get the ftp server up and running so I can copy some files off the machine. Once I get that done, I'm wiping it out anyway, so a permanenet solution isn't required if it's not necessary.

Thanks in advance!
Brad Ball
Go to the top of the page
 
+Quote Post
hughesjr
post Nov 29 2003, 10:09 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I'm not exactly sure why everything set to 777 would cause the error that you see. Why not just setup an FTP server on the other PC ... and use FTP as a client from the broken PC. (or better yet, use sftp if the other PC is linux).

It also seems you have a problem with the file:

/etc/group

Is it possible that that file is either missing or not chmod'ed as readable by root?


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
monroe
post Nov 29 2003, 06:36 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-November 03
Member No.: 1,878



Nice Icon! (I just got home form the UK vs UT football game smile.gif ) ....

As far as setting up ftp goes, I'm copying files off the linux box to 3 different machines, so it would be quite a pain to have to setup FTP servers on all 3 of those machines, although I guess that's what I'll end up doing as a last resort. As far as the /etc/group file goes, I checked it. It's there, it's readable by everyone (it got chmod'd to 777 with everything else).
Go to the top of the page
 
+Quote Post
hughesjr
post Nov 29 2003, 08:07 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



That game could have gone better ... (at least from my point of view). At least it's basketball season now!

Try setting the permissions on the directory /etc/security and etc/securetty like this:

chmod 755 /etc/security
chmod 644 /etc/security/*
chmod 644 /etc/securetty


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
monroe
post Nov 29 2003, 09:26 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-November 03
Member No.: 1,878



No kidding .. I thought the refs made some pretty horrible calls, but that's for another fourm smile.gif


This is where I'm running into problems ... Since I can't get root, I can't change permissions on anything that's owned by root, so I'm kinda stuck ... I'm gonna try to boot into single user mode and see if I can get in that way.
Go to the top of the page
 
+Quote Post
hughesjr
post Nov 29 2003, 09:29 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You should be able to get into single user mode and then change the permissions ... I think securetty might be the problem ... I have seen that file cause problems similar to this in the past.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
monroe
post Nov 29 2003, 09:37 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-November 03
Member No.: 1,878



AWESOME! That did it!
Logged into single user mode ... chmoded those files/foloders and rebooted .. Now I can log in as root again!

I probaly still ahve some other problems, I know sshd won't start cause it's Key files aren't "protected". But I should be able to take care of those kinds of things. It's just hard to get anything done when you can't get root smile.gif

Thanks Again!

GO CATS!
Go to the top of the page
 
+Quote Post
chrisw
post Nov 30 2003, 12:01 AM
Post #8


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



GO CATS...we got this thing...
everytime a uk player shoots a 3
we take a shot of liquour....pretty cool huh....
we just hope it rains 3 during the game...


--------------------

Chris W.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 08:40 AM