Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Apache Running But Not Responding, Apache running but not responding
post Nov 11 2002, 05:46 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 3
Joined: 11-November 02
Member No.: 133

unsure.gif I installed RedHat Linux 8.0 on a PC. I think its kernal 2.14.
Apache was installed with it, version 2.040 I think. I have started Apache with /usr/sbin/apachectl -k start
The error log /var/log/httpd/error_log said it was operating normally.

We are not using SSL, but the ssl_error_log gave warnings about RSA.

The Linux machine has a static ip. I was able to ping the server from my other machine. I tried browsing to it though, and it did not work. I typed the server's IP address into the browser URL line.

In the httpd.conf, I have set the Listen to 80 and ServerName to the server's (internal network) IP address. The error log does not show anthing to say anything wrong, the access_log stays empty.

Can anyone tell me why Apache is not serving.
Go to the top of the page
+Quote Post
Start new topic
post Nov 11 2002, 07:12 AM
Post #2

Its GNU/

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3

First off, try to restart the server with /usr/sbin/apachectl restart . As far as my memory serves me, when you append the '-k' on the command line for a daemon, it usually stops the service, not starts. The second thing is, for arguments sake, try accessing the server on secure, that is, in the URL bar, enter in https://theip and see if you connect. It might be that apache is running in secure ssl mode rather then regular modes.

Corey Quilliam
(former) Administrator

Want to help out Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 20th March 2018 - 08:49 AM