Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Lilo Help
theio
post Oct 1 2002, 01:34 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 1-October 02
Member No.: 9



i just installed windoze 98 on a different partion so that i could use it for emulating stuff in wine... but it decided to take over my master boot record now it wont boot. i mannaged to boot to linux with abackup disk i have but i want it back on my master boot record. Ive tried the 'lilo -r /' and '/sbin/lilo -r /' they both give me the same error which is:
Device 0x0300: Invalid partition table, 1st entry
3D address: 1/0/1021 (16402365)
Linear address: 1/195/963 (15482880)
i am really dont know what to do.... can any one out there help me!? unsure.gif

edit: im running Slackware with the 2.4.19 kernel
Go to the top of the page
 
+Quote Post
Joey
post Oct 1 2002, 06:06 AM
Post #2


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



what does running plain:

/sbin/lilo


give you?
Go to the top of the page
 
+Quote Post
theio
post Oct 1 2002, 01:42 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 1-October 02
Member No.: 9



same thing
Go to the top of the page
 
+Quote Post
Joey
post Oct 1 2002, 01:47 PM
Post #4


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



what are your partitions currently set up like? If you're not sure, run fdisk /dev/hda in linux and hit the letter p, you should see something like this:

Device Boot Start End Blocks Id System
/dev/hda1 * 1 4 32098+ 83 Linux
/dev/hda2 5 1663 13325917+ 83 Linux
/dev/hda3 1664 1918 2048287+ 83 Linux
/dev/hda4 1919 2431 4120672+ f Win95 Ext'd (LBA)
/dev/hda5 2085 2237 1228941 83 Linux
/dev/hda6 2238 2364 1020096 83 Linux
/dev/hda7 1919 2007 714829+ 82 Linux swap
Go to the top of the page
 
+Quote Post
theio
post Oct 1 2002, 02:39 PM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 1-October 02
Member No.: 9



Device Boot Start End Blocks Id System
/dev/hda1 * 1025 5168 31328640 c Win95 FAT32 (LBA)
/dev/hda3 4064 5168 8353800 5 Extended
/dev/hda5 4064 5039 7373803+ 83 Linux
/dev/hda6 5039 5168 979902 82 Linux swap
Go to the top of the page
 
+Quote Post
Joey
post Oct 1 2002, 04:55 PM
Post #6


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



what does your lilo.conf look like (paste it full if you want)
Go to the top of the page
 
+Quote Post
theio
post Oct 1 2002, 05:03 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 1-October 02
Member No.: 9



# LILO configuration file
# generated by 'liloconfig'
#
# Start LILO global section
lba32 # Allow booting past 1024th cylinder with a recent BIOS
boot = /dev/hda
message = /boot/boot_message.txt
prompt
timeout = 1200
# Override dangerous defaults that rewrite the partition table:
change-rules
reset
# VESA framebuffer console @ 1024x768x256
vga = 773
# Normal VGA console
# vga = normal
# VESA framebuffer console @ 1024x768x64k
# vga=791
# VESA framebuffer console @ 1024x768x32k
# vga=790
# VESA framebuffer console @ 1024x768x256
# vga=773
# VESA framebuffer console @ 800x600x64k
# vga=788
# VESA framebuffer console @ 800x600x32k
# vga=787
# VESA framebuffer console @ 800x600x256
# vga=771
# VESA framebuffer console @ 640x480x64k
# vga=785
# VESA framebuffer console @ 640x480x32k
# vga=784
# VESA framebuffer console @ 640x480x256
# vga=769
# End LILO global section
# DOS bootable partition config begins
other = /dev/hda1
label = DOS
table = /dev/hda
# DOS bootable partition config ends
# Linux bootable partition config begins
image = /boot/vmlinuz
root = /dev/hda5
label = Linux
read-only
# Linux bootable partition config ends
Go to the top of the page
 
+Quote Post
theio
post Oct 1 2002, 05:05 PM
Post #8


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 1-October 02
Member No.: 9



?????????????????? LILO INSTALL ERROR # 1 ??????????????????
? Sorry, but the attempt to install LILO has returned an ?
? error, so LILO has not been correctly installed. ?
? You'll have to use a bootdisk to start your machine ?
? instead. It should still be possible to get LILO ?
? working by editing the /etc/lilo.conf and reinstalling ?
? LILO manually. See the LILO man page and documentation ?
? in /usr/doc/lilo/ for more help. ?
?
? < OK > ?
????????????????????????????????????????????????????????????





sigh *shrug*
Go to the top of the page
 
+Quote Post
Joey
post Oct 1 2002, 05:17 PM
Post #9


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



hmm, what did you use to partition your drive?

Why does your first partition start at 1025 instead of at 1

/dev/hda1 * 1025 5168 31328640 c Win95 FAT32 (LBA)

Maybe this is what is causing lilo to break..
Go to the top of the page
 
+Quote Post
theio
post Oct 1 2002, 08:43 PM
Post #10


Whats this Lie-nix Thing?
*

Group: Members
Posts: 7
Joined: 1-October 02
Member No.: 9



good call, i deleted the windows partition and remade it... works great now! Thanks man
Go to the top of the page
 
+Quote Post
Joey
post Oct 1 2002, 09:03 PM
Post #11


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



No prob smile.gif
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th December 2017 - 03:13 AM