Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Permissions Of Mounted Folders, non-root users not allowed to enter
frodo44
post Nov 3 2003, 06:17 PM
Post #1


./configure
***

Group: Members
Posts: 95
Joined: 2-December 02
Member No.: 213



Hey, I'm having a problem with my mounted FAT32 partitions where I can enter them from root, but not from my other account, even though it has root privileges too. I've tried changing permissions in every way that I can think of, but I still can't enter the directory, even though the user has read priviliges. Any ideas? Does it maybe have to do with the fact that it's a mounted FAT32 partition? Any ideas would be helpful.

Thanks,
Eric


--------------------
Windows XP; Debian 3.0r2 (Woody)
---
Shuttle AK32 Mobo w/ Athlon XP 1700+ @ 266 FSB
GeForce 4 mx440 64mb
Turtle Beach Santa Cruz 5.1 Surround Sound
256 MB DDRAM
Seagate 80gb, Western Digital 40gb
---
weezle@charter.net
Go to the top of the page
 
+Quote Post
michaelk
post Nov 3 2003, 07:31 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,796
Joined: 23-January 03
Member No.: 360



Make sure the directory that you mount the FAT32 partition to has read / write permissions as desired unmounted. Then make sure the umask option is set correctly in the fstab file. Remember it is backwards from what you would use with the chmod command.

umask=000 means read / write for all users.

Are you using any other option like suid in fstab?
Go to the top of the page
 
+Quote Post
frodo44
post Nov 3 2003, 08:32 PM
Post #3


./configure
***

Group: Members
Posts: 95
Joined: 2-December 02
Member No.: 213



I'll have to say that was all greek to me. Here's it's line in the fstab file:

CODE
/dev/hda3        /e               vfat        defaults         1   0


So, would I put umask=000 in place of defaults? Also, I have no idea what the suid is...
I checked the /dev/hda3 file, and set its permissions to read/write for everyone, with no execute priviliges, since there are no linux executables on it. Thanks for the help.

Eric


--------------------
Windows XP; Debian 3.0r2 (Woody)
---
Shuttle AK32 Mobo w/ Athlon XP 1700+ @ 266 FSB
GeForce 4 mx440 64mb
Turtle Beach Santa Cruz 5.1 Surround Sound
256 MB DDRAM
Seagate 80gb, Western Digital 40gb
---
weezle@charter.net
Go to the top of the page
 
+Quote Post
frodo44
post Nov 3 2003, 08:36 PM
Post #4


./configure
***

Group: Members
Posts: 95
Joined: 2-December 02
Member No.: 213



All right, that helped... Thank you very much for your help.

Eric


--------------------
Windows XP; Debian 3.0r2 (Woody)
---
Shuttle AK32 Mobo w/ Athlon XP 1700+ @ 266 FSB
GeForce 4 mx440 64mb
Turtle Beach Santa Cruz 5.1 Surround Sound
256 MB DDRAM
Seagate 80gb, Western Digital 40gb
---
weezle@charter.net
Go to the top of the page
 
+Quote Post
hughesjr
post Nov 4 2003, 07:49 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Just for future searchers .... umask is a setting in your users profile on Linux ...(usually set in each users home directory in a file called .bash_profile).

The default setting is 002 ...

umask is a "User Mask" that subtracts from standard file creation permissions ... if the standard permissions are rw-rw-rw- (or 666) then 002 is removed, making the file creation permissions 664 (or rw-rw-r--)...if you change your umask to 022, then the file creation permisions would be 644, etc.

To change the umask for a given user, edit that users .bash_profile and add (or edit) a line that says:

umask=002

to whatever you want it to be.

With some versions of Linux (and UNIX) it is better to use an extra zero in the beginning ... like this:

umask=0002

or

umask=0022

I always use 4 digits...the first digit is just a placeholder.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 11:04 PM