Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Desperate - Samba Problems, User authentication from XP desktops
tcomtech
post Oct 27 2003, 09:03 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 27-October 03
Member No.: 1,709



I am in dire need of help. I was supposed to turn a fully configured server over to the customer today but needless to say the Samba piece has squashed that. Here is the scenario:

Compaq Proliant Server can only run Red Hat 8.0 because of buit in raid controller (another nightmare in itself) so we installed and configured 8.0.

From that point customer has 2 desires, FTP Access with chrooted users, and Samba for his Windows environment. The FTP was smooth but the Samba I am about to jump of the Tobin Bridge!!!

The issue I am having is that the configuration appears to be fine. The end result is that from the XP desktop when attempting to connect to the resource it will prompt for a username and password, no matter what I put in it just reprompts and reprompts forever. I will list the things I have done to attempt to remedy:

1. Compare to a current running samba server smb.conf file, they are the same config, only difference is the box.
2. Match line for line with smb.conf file exactly still no connectivity.
3. Download webmin, attempt to install that manner still no go!!

I am wits end with pressure reigning down on me!! Can anyone help me out with a sample config or any pointers. I appreciate in advance and bottom line am getting hooked on this Linux thing!!!!

Thanks, you can even email me direct if you want
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 27 2003, 11:53 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



one thing to check is that the machines know each others names properly...

Is there a Wins server (other than the samba server) on the Windows Network ... if so, make sure you have the WINS Client (and not the WINS server) enabled in the samba.conf file.

Also make sure your samba server's hostname and fully qualified domain name are in the /etc/hosts file on the samba server.

Make sure the smbd and nmbd processes are running ...

ps -ef | grep mb

(should look like this)
CODE
root      1970     1  0 21:15 ?        00:00:00 smbd -D
root      1974     1  0 21:15 ?        00:00:00 nmbd -D


If not, /etc/init.d/smb start to see if it will start...

The following in smb.conf will create a browseable file directory for users on the samba server:

CODE
[homes]
  comment = Home Directories
  browseable = yes
  writable = yes
  valid users = %S
  create mode = 0664
  directory mode = 0775


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 11:25 PM