Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Gasp! Root Can't Change Permissions!, Executables not working, root cant chmod
merlin@antipixel...
post Oct 22 2003, 01:04 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 22-October 03
Member No.: 1,669



Bah. For some reason, 90% of everything in /usr/bin and /usr/sbin wont work. An ls shows that everything is there but it says that it doesn't exist. I've tried launching them every possible way, but I noticed that certain things are not being done at startup, and its due to this. The permissions look fine on those executables, but root doesn't have the power to chmod. Why not?? This is reeeeally odd and I haven't seen anything like this before. Please help, this is an email server for a school district. Thanks!
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 22 2003, 05:57 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



so an ls -al t* in /usr/bin shows info that looks like this:

CODE
-rwxr-xr-x    1 root     root        16840 Mar 13  2003 tac
-rwxr-xr-x    1 root     root       163917 Mar 13  2003 tack
-rwxr-xr-x    1 root     root        35940 Mar 13  2003 tail
-rwxr-xr-x    1 root     root       521583 Mar 17  2003 taskjuggler
-rwxr-xr-x    1 root     root        96724 Mar 17  2003 tbl


(I just picked the top couple files ... what is key is the owner and group are both root and the file permissions are 755 {that is -rwxr-xr-x}).

Next, check the file /etc/passwd and look at the root user ... this command will show you root's entry:

cat /etc/passwd | grep root

the output should look similar to this:

CODE
root:x:0:0:root:/root:/bin/bash


The important part is that the 3rd and 4th sections are both 0 (that is the userid and group id numbers ... the user who is 0 0 is the real root user, reguardless of the names ... if your root user is other than 0, it could mean someone has compromised the machine.

You might also do the command:

cat /etc/passwd | grep :0:0:

and make sure only the user root is listed as a :0:0: user....

Another potential problem could be the root user's path .... type the command (when logged in as root):

env | grep PATH

You may have several items ... the key one being PATH=... here is mine from a default install of SUSE 8.2:

PATH=/sbin:/usr/sbin:/usr/local/sbin:/root/bin:/usr/local/bin:/usr/bin:/usr/X11R6/bin:/bin:/usr/games:/opt/gnome2/bin:/opt/gnome/bin:/opt/kde3/bin:/usr/lib/java/jre/bin:/opt/gnome/bin

the above is all one line ... the important parts for your situation are that /sbin:/usr/sbin:/bin:/usr/bin:/usr/X11R6/bin are in the path statement (not necessarily in that order, just that all are there).

If all that is right, then lets look for something else...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
jashall
post Oct 23 2003, 03:21 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 23-October 03
Member No.: 1,683



If you get this working, please tell what you did. I'm in the same boat running Mandrake 9.1.

Everything worked great, until the other day I tried to set up Samba. Now, I can no longer run commands in my username as well as root.

I can list the directory, see the file, even copy/past the command to make sure no spelling errors and then get command not found. Can't even use the command shutdown

Everything listed in the remarks above looks correct on my machine.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 05:40 AM