Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> .login File Help/rh9.0, help with local .login file
Jodene
post Oct 21 2003, 09:43 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 21-October 03
Member No.: 1,667



Hello everyone. I am trying to add some paths to my csh.login file. I understand that I am to copy the etc/usr/csh.login file into my /home directory, then change the name to .login and make changes to the .login file. I copied the file to my /home directory, and then, when I changed the filename to .login, it no longer lists using "ls" or "dir." However, I can edit the file with vi, which I did. But the new paths and prompt statement are not being invoked. I know I put in the correct statements because they work at the terminal command prompt. I am using the tcsh shell. Does anybody have any advice about this? Many thanks in advance.

Newbie with numb brain,
Jodene
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 22 2003, 03:21 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



First the easy problem ... things that begin with a . don't show up on ls, do a ls -al and you will see them.

change your .login script to make it execcutable....

chmod 755 .login

Have you changed the default shell to tcsh for the user, or are you just running tcsh from a bash shell?

I use .tcshrc to contain my variables for tcsh...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Jodene
post Oct 22 2003, 09:02 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 21-October 03
Member No.: 1,667



Thanks guru!! You're the best. I changed to tcsh from bash in the .passwd file so that the tcsh would be the operating shell when I boot up. Is that the right thing to do? Or should I stay in bash? Do you prefer bash?

Jodene
Go to the top of the page
 
+Quote Post
Jodene
post Oct 22 2003, 09:57 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 21-October 03
Member No.: 1,667



Me again. Acutally, I've just discovered that the changes I made to the /etc/.passwd file are not being invoked either. I set the root and user shells to tcsh, but when I log on, they are set to bash. Aren't these files already executable?

Also, the new paths I set in the .login file are still not happening...is that because I'm in bash, not tcsh?

A final question...I have an /etc directory, but I also have an /usr/etc directory. Should I have both of these? the /usr/etc directory doesn't appear to have anything in it, but the /etc directory has many files, including the .passwd file.

Thanks again for your help!

Jodene
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 22 2003, 07:38 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



try putting the varible commands in the file .tcshrc.

The command for setting variables in tcsh is like this:

setenv ORACLE_HOME test

It is the same as this in bash:

export ORACLE_HOME=test

-------------------------------------
A /usr/etc directory is OK ... some programs may use it in the future.
------------------------------------
The file in /etc is passwd, not .passwd.

Unless you really require C-shell (or are doing it for learning), I would recommend that you stay with bash. Bash is the linux standard...If you have an application that requires C-shell, then that is a different story.

Here is the prompt command from my .tcshrc:

CODE
set prompt='[%n@%m %c]# '


This is very similar:
CODE
set prompt=[`id -nu`@`hostname -s`]#


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 11th December 2017 - 02:03 PM