Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Samba - Read Only, Same problem, after changing mask
RHG
post Oct 18 2003, 02:26 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-October 03
From: New Brunswick, Canada
Member No.: 1,575



I'm using Samba and when I create a new file other user can only access it as a read only file. I have to do a chmod -R 755 command to fix it. I tried change the create mask to 755 but that still didnt work.

Please help thanks

# Global parameters
[global]
workgroup = RHGREEN
netbios name = CFS
server string = Server
encrypt passwords = Yes
pam password change = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *New*UNIX*password* %nn *ReType*new*UNIX*password* %nn
unix password sync = Yes
log level = 2
log file = /var/log/samba/log.%m
max log size = 50
name resolve order = wins bcast lmhosts hosts
time server = Yes
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
domain admin group = @admins
logon script = netlogon.bat
logon path = \%Lprofiles%U
logon drive = h:
logon home = \%L%U
domain logons = Yes
os level = 64
preferred master = Yes
domain master = Yes
create mask = 0755
hosts allow = 127.0.0.1 192.16
socket options = TCP_NODELAY IPTOS_LOWDELAY SO_SNDBUF=8192 SO_RCVBUF=8192
domain admin group = @admins
logon script = netlogon.bat
logon path = \%Lprofiles%U
logon drive = h:
logon home = \%L%U
domain logons = Yes
os level = 64
preferred master = Yes
domain master = Yes
create mask = 0755
hosts allow = 127.0.0.1 192.168.1.0/255.255.255.0

[homes]
comment = Home Directories
read only = No
browseable = No

[profiles]
path = /home/samba/profiles
read only = No
only user = Yes
browseable = No

[netlogon]
comment = Network Logon Service
path = /home/netlogon
write list = @admins
browseable = No

[shared]
path = /home/share
read only = No



: unsure.gif
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 19 2003, 10:24 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



755 means only the file owner can access the file created in write mode (rwxr-xr-x).... 766 (rwxrw-rw-) or 777(rwxrwxrwx) would allow everyone to access the file in read/write mode ... and 764 (rwxrw-r--) or 774 (rwxrwxr--) would allow only members of the creators group to have read/write permissions.

You also have several items repeated in the Global section ... each entry should be there only once...

Also, check what the linux users umask is ... use the command umask when logged into the linux machine (from a terminal window) as that user...

the output needs to be 0002 (not 0022) if you want to have the user create files readable by others in his group, or 0000 if you want the user to create files readable by everyone...

You can set umask in the file .bashrc with this command:

umask=0002

or

umask=0000


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
RHG
post Oct 20 2003, 10:28 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-October 03
From: New Brunswick, Canada
Member No.: 1,575



I checked the umask and it was 0022. But I'm not clear on how to change the settings.

How do I set umask in the file .bashrc?
Go to the top of the page
 
+Quote Post
RHG
post Oct 20 2003, 02:15 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 7-October 03
From: New Brunswick, Canada
Member No.: 1,575



I got it fixed, I made a dumd error
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 10:19 AM