Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Lost -now Can't Boot
post Oct 7 2003, 05:10 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 7-October 03
Member No.: 1,578


I recently tried upgrading to libc2.2 (from 2.1.3) in order to get the lastest version of evolution working with my RH6.2 system. This broke a bunch of stuff so I uninstalled the glibc2.2 rpm and re-installed libc2.1 This mostly worked but evolutron wouldn't launch and I was getting a bunch of locale error. Poking around I saw that the sym link in /lib for (or something close, can't remember exactly) was still pointing to libc.2.2.? (which I thought would have been removed when I uninstalled the package) , I tried manually pointing this to the 2.1 static lib but ldconfig would re-establish it to point to 2.2. Brilliantly I manually removed libc.2.2 which immediately hosed all executables linked to it, including mv,cp, ln etc. I booted to a ramdisk, mounted the /lib partition and established the link manually. Now my machine won't boot. I get a init error: can't load shared object - too short.

Any ideas?

Jeff Patterson
Go to the top of the page
+Quote Post
post Oct 8 2003, 06:44 AM
Post #2

Its GNU/

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151

I think the link you want to do is this:

Boot (like you did before) an go to /{mount_dir}/lib

ln -s

Have you updated your RH 6.2 to the latest RH security patches? If so, here is where you can get the updated glibc from redhat (assuming you have a RH machine):

If not, you can use your original RH 6.2 cd, or you can get a 6.2 ISO here:
once you get boot with the ramdisk, you can use the chroot command and then try to do installs....

chroot /{mount_dir} /bin/bash

then you can try again to install rpms....

(substitue you mount directory on ram disk for {mount_dir}
Now might be a good time to consider an upgrade to RH 7.3, 8.0 or 9.0 depending upon your hardware.

Johnny Hughes
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th March 2018 - 01:13 AM