Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> System Won't Boot Into X, System won't Boot into X
Archer
post Sep 30 2003, 12:53 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 30-September 03
Member No.: 1,549



My Red Hat 9 system mysteriously decided that it was suddenly going stop halfway through it's boot process. I'm new to linux and don't know how to fix the problem.
The boot process seems to run through normally until it reaches the "configuring kernel parameters ...........[ OK ]" then it stops.
That's it. The only way I can get it to go any further is the press Ctrl-C, It will then proceed a few more lines but will output error messages like: touch: <directory>/<directory>/<filename> Read-Only Access - or something similar for about 4 files, then it stops again and is completely dead.

Any Help would be much appreciated.
Peter

My System:
P3 800
Asus CUV4X mainboard
Asus AGP V7700 Video
512MB SDRAM
30GB HDD (Seagate)
Red Hat 9 with latest Nvidia Drivers (4496) Work perfectly for a week or so.
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 30 2003, 05:10 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Did you do anything (like a kernel upgrade)?

Does the [OK] show up in the line:

Configuring kernel parameters: .........[OK]

or does it hang waiting for the [OK]?

This is when the file /etc/rc.d/rc.sysinit is running, and the next step (after Configuring kernel parameters) that should be printed to the screen is:

Setting clock


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Archer
post Sep 30 2003, 10:48 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 30-September 03
Member No.: 1,549



Hey hughesjr,

I haven't done anything in the way of a kernel upgrade, the only "upgrades" to speak of that I've done since installing the system are as follows:
Upgraded Mozilla to version 1.4 using rpm (most recent upgrade)
Installed the Java Development Kit 1.4.2
Installed the Nvidia Drivers

Configuring kernel parameters does show the ...... [OK], It's after the [OK] is displayed that everything stops.

I guess this means it's having trouble with the "Setting clock" part of the process, I assume that this is setting the Linux system clock from the BIOS clock or something similar?
What would cause this?

Thanks for your help
Peter
Go to the top of the page
 
+Quote Post
Archer
post Oct 1 2003, 12:11 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 30-September 03
Member No.: 1,549



Well, what do you know, Fixed it biggrin.gif .... for now at least anyway.

I pulled the power right off the system for an hour or so, plugged it back in and it booted fine.

I'm thinking that there was some corruption in the memory that was preventing the clock from being read properly and causing the system to hang. Pulling the power off the system forced the memory to be completely re-initialised.

Any Ideas on what would cause this, just so I can try and prevent any future problems of this type?

Thanks
Peter
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 1 2003, 05:57 AM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



CODE
# Set the system clock.
ARC=0
SRM=0
UTC=0
                                                                               
if [ -f /etc/sysconfig/clock ]; then
  . /etc/sysconfig/clock
                                                                               
  # convert old style clock config to new values
  if [ "${CLOCKMODE}" = "GMT" ]; then
     UTC=true
  elif [ "${CLOCKMODE}" = "ARC" ]; then
     ARC=true
  fi
fi
                                                                               
CLOCKDEF=""
CLOCKFLAGS="$CLOCKFLAGS --hctosys"

case "$UTC" in
  yes|true)
   CLOCKFLAGS="$CLOCKFLAGS --utc";
   CLOCKDEF="$CLOCKDEF (utc)";
;;
  no|false)
   CLOCKFLAGS="$CLOCKFLAGS --localtime";
   CLOCKDEF="$CLOCKDEF (localtime)";
;;
esac
                                                                               
case "$ARC" in
    yes|true)
       CLOCKFLAGS="$CLOCKFLAGS --arc";
       CLOCKDEF="$CLOCKDEF (arc)";
  ;;
esac
case "$SRM" in
    yes|true)
       CLOCKFLAGS="$CLOCKFLAGS --srm";
       CLOCKDEF="$CLOCKDEF (srm)";
  ;;
esac

/sbin/hwclock $CLOCKFLAGS
                                                                               
action $"Setting clock $CLOCKDEF: `date`" date


The above code is where you were hanging ... where it says action $"Setting clock $CLOCKDEF: `date`" date is the place that text would appear on the screen ... SO, the only thing I can see that could cause a hang is:

/sbin/hwclock $CLOCKFLAGS

There are a couple problems like this on the web, but I'm not sure what to make of it...

http://www.ale.org/archive/ale/ale-2002-05...5/msg00528.html
http://www.ussg.iu.edu/hypermail/linux/ker...006.2/0397.html
http://www.linuxtv.org/mailinglists/vdr/20...3/msg00564.html
http://www.mail-archive.com/cooker@linux-m...m/msg64342.html

None of these posts really point out a fix for the problem ... If the system clock is going dead, that could cause a hang (the system will be waiting for a tick and it doesn't exist), so I would replace the watch battery on the motherboard...but that is just a shot in the dark.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
Archer
post Oct 6 2003, 09:12 PM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 30-September 03
Member No.: 1,549



After a little further investigation, I found that this problem with setting the colck only occurs in a specific situation on my system. It only happens when the system has been set to automatically boot at a specific time in the BIOS. Basically there's an option in the BIOS that allows the system to boot automatically at the specified time.

If this is enabled the system stops during the boot when trying to set the clock.
My question is why?

What is so different between booting in this way and me pushing the button to turn the system on? The system is still shutdown in the same way so it should be booting from a similar state.

Any Ideas?

Peter
Go to the top of the page
 
+Quote Post
hughesjr
post Oct 7 2003, 05:46 AM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I'm not sure why it would be different, but the error seems to be that the hwclock program is waiting for a tick ... and it looks like it will wait forever. It seems that the BIOS locks the memory location when you boot that way, and hwclock can't connect to the clock normally ....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 01:22 AM