Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Outbound Email Problem Or I'm A Blonde, Cant send email outside of lan
bitessy
post Sep 25 2003, 05:24 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 25-September 03
Member No.: 1,524



I am having a problem with the email server; it won't send mail outside of the LAN. Here are all the details. I have a firewall/router between the LAN and the public Internet. I have a Mandrake 9.0 server behind the firewall serving a web page, and now I want it to serve email as well. I have a domain registered, and a MX record all pointing to the public IP address of my firewall, with port-forwarding from there to the server. I tested the port-forwarding by telneting to ports 25 and 110 through the firewall, and was successful. I know about the security problems with telnet, so after testing, I turned off telnet. I Configured Postfix as my MTA, and I can use MS Outlook to send and receive from within the LAN, and I can even receive from the outside world; I tested using my yahoo email account, and I get it every time. My issue is that Mail won't go outside my LAN to be delivered else ware. I suspect that I missed something, but I don't know what it is. Any help that you GURUs can give me to point me in the right direction will be greatly appreciated.

Thanks,
Tessy
bitessy at yahoo dot com
Go to the top of the page
 
+Quote Post
Joey
post Sep 25 2003, 05:33 PM
Post #2


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



What happens when you try and send mail?
Go to the top of the page
 
+Quote Post
bitessy
post Sep 26 2003, 12:12 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 25-September 03
Member No.: 1,524



4 hours later I getthe following mail from mailer-daemon.mail.mydomain.com:

This is the Postfix program at host mail.XXXX.com.

####################################################################
# THIS IS A WARNING ONLY. YOU DO NOT NEED TO RESEND YOUR MESSAGE. #
####################################################################

Your message could not be delivered for 4.0 hours.
It will be retried until it is 5.0 days old.

For further assistance, please send mail to <postmaster>

The Postfix program

<USERNAME@YYYYYYZZZZZ.com>: transport is unavailable

I have one of these for each mail I have sent.
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 26 2003, 11:14 AM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Here is where to start. Once you have the error in the log identified then a fix can be found...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 08:57 AM