Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Indepth Networking Problem! (linux Newbie)
post Sep 21 2003, 08:57 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 2
Joined: 21-September 03
Member No.: 1,491

Hi I have installed mandrake 9.1 on an hp e-pc40, however I cant get any LAN access outside of the loopback or static IP i set, can anyone shed any light on this???

the machine can not ping anyother machine on the LAN, connects into a netgear ds108 8 port hub 10/100 dual speed

ip and sm are correct, also tried dhcp it doesnt find the server and gives itself which I think is similar to the w2k auto config cant find dhcp server addresses???

help I am rapidly going bald!, I am also a Linux newbie! however very very keen to move from windows, this is proving a first and very challenging task!

the driver was auto loaded (eepro100) during the auto 3 cd setup (automatically)

examples of other ip's connected to the same hub are or neither can be pinged from the linux box or can ping the linux box, but work fine with each other, the linux box reports when pinging for example you get Reports Destination Host Unreachable

I can ping loopback and and get reply's

arp does not return anything just back to the prompt and ifconfig shows:-

eth0: Link Encap: Ethernet Hwaddr 00:04:23:02:38:52
inet addr: Bcast Mask
RX Packets:0 errors:0 dropped:0 overruns:0 frame:0
TX Packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX Bytes:0 (0.0 cool.gif TX Bytes:0 (0.0 cool.gif
Interrupt:5 Base Address:0x9000

lo Link encap:Local Loopback
inet addr: Mask:
RX Packets:30 errors:0 dropped:0 overruns:0 frame:0
TX Packets:30 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX Bytes:1994 (1.9 kb) TX Bytes:1994 (1.9 kb)

route shows * U O O O eth0 * U O O O lo
default UG O O O eth0

mii-tool shows

eth0: Negotiated 100BaseTX-HD, link ok

I can negotiate 10/100 HD link ok

adapter is i82557

ethernet adapter has been used before with windows installed

Heres where I am at so far, its getting more indepth!

I have pinged from the linux box

shows reports destination host unreachable

I ran a network analyser and can see the broadcast from the linux box asking for the holder of the IP's MAC addr, and the reply with the MAC addr from .0.1 however this is then not cached in arp on the linux box and no further activity except another broadcast IP to MAC addr request and a reply with MAC addr from .0.1 until i ctrl+c on the linux box

also when I ping .0.2 from .0.1 it sends the broadcast asking for the MAC Addr of .0.2 and it does not get a reply from .0.2 (linux box)!


Go to the top of the page
+Quote Post
post Sep 22 2003, 05:42 PM
Post #2

Its GNU/

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151

This site discusses the need to change the settings of this card if the switch/hub doesn't properly do NWay autonegotation.

This sounds like a problem I have seen with 100BaseT being negotated, but the cable only supporting 10BaseT ... is it possible that the cable plugged into the box is not Category 5 ... or that it has a bad end?

See if you meet these conditions ... you may need to shift to 10BaseT, follow the directions on the above page to switch to 10BaseT if necessary.

You can also download a driver for the card from Intel ... but I would try to stick with the kernel driver from the main kernel.

Johnny Hughes
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
+Quote Post
post Sep 22 2003, 06:13 PM
Post #3

Whats this Lie-nix Thing?

Group: Members
Posts: 2
Joined: 21-September 03
Member No.: 1,491


I have tried the settings from that site previously but no joy, I originally thought negotiation problem but had tried 100/10 HD FD to no avail!

I have now come to the conclusion that it is the base unit which is causing the problems, it is one of the hp e-pc40 jobs, which is a very small unit everything on board, no pci slots/isa or floppy, and I am becoming swayed to the fact that there may be some part of the mb that is not fully utilised/supported within linux as yet and is causing some strange net problems, it has to be something like that I have tried everything else!

however as a linux newbie it has been a steep learning curve but I have enjoyed every minute of it!

I am quite of the persuasion that everyone should have an os like linux so you get to grips with the computer itself and understand
whats going on instead of an os which never really gets you involved!.

Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 19th July 2018 - 09:54 PM