Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> Please Help; Monitor Disappears, Can't Run Linux w/o a Monitor...
cagey cretin
post Sep 9 2003, 11:19 PM
Post #1


./configure
***

Group: Members
Posts: 96
Joined: 9-September 03
Member No.: 1,413



I have a problem that has plagued me for the past two years: I haven't been able to install Linux.

I have 3 CD-set ISOs for Madrake 9_1 and Redhat 9; both eyield the same result (after the install process).

After the initial re-boot, my screen goes dead. As if it has powered
down. All my hardware meets with redhats HCL seal of approval, and was found by the OS as it was installing. I actually made it through the install process of all the OSes I tried. Upon re-boot, after listing all
services at start up, my monitor goes blank. All the tests during
install to see if the settings worked, did in fact work.

The monitor goes into sleep mode, by appearances.

Someone on another forum suggested trying another monitor. I did; I still fail to get Linux up and running.

Over the last two years I have used these books:

* Linux Bible (Hungry Minds)
* Building a Linux Internet Server (New Riders)
* RHCE Certification Study Guide (Osbourne/Syngress)
* Mastering RedHat 6.0 (Sybex)
* Redhat 9 Documentation PDF
* Redhat 7.1 Documentation PDF
* Mandrake 9.1 Documentation PDF
* Mandrake 7 Documentation PDF

Let me get this out now:

I have shit for brains, I don't know what I am doing, etc.

I would still appreciate any pointers/thoughts.

Joe Wilk
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
kk19115
post Sep 10 2003, 10:26 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 9-September 03
Member No.: 1,414



I'm running AMD 850 NVIDIA GForce FX 5200. I realized that during installation I picked my video card out of a list rather that leaving it at the generic VESA driver. I found a post that was interesting..

Hi,

I recently bought a Sony VAIO GRT170 notebook computer and I'm trying to
install RedHat Linux 9 alongside Windows XP. I'm pretty sure the
dual-booting works properly, since the GRUB bootloader comes up at startup
like it's supposed to, but when I choose Linux, I get a blank screen (after
all the intialization commands). From what I've read so far, I think this is
because of the video card (NVIDIA GeForce4 FX Go 5600, 64MB); during
installation, instead of leaving the generic VESA driver selected, stupid me
went through the list and chose the one that most closely matched. My
question is: how do I fix this without completely redoing the installation?
I downloaded the updated Linux drivers from NVIDIA's website, but I have no
idea what to do with them. Since I can't even really start Linux at all, I
have no idea what to do. I'm a complete newbie, so step-by-steb help would
be very much appreciated.

Thanks,

Sabir

You can boot to runlevel 3 (a character based startup) and then edit your
/etc/XF86Config file to properly set the video information.

If you're not sure how to edit files in redhat character based mode, I
recommend nano ... it was probably installed ... and it is fairly easy to
use.

When you load nano it will have a menu with commands, they will look like
this:

^G Get Help ^O WriteOut ^X Exit

The ^ means use the Ctrl key ... so Ctrl-o will open the write out (save the
file) option then Ctrl-x will exit....

Here is how to boot to runlevel 3....
-------------------------------------------
1. Start the PC ... when you get to GRUB, press the e key to go to edit
mode.
2. Find the Kernel line ... it will look something like this:

kernel /vmlinuz-2.4.20-18.9smp ro root=LABEL=/

3. Select this line using the Arrow Keys and with the line selected, press e
to edit the line.

4. Move to the end of the line, and add a space and 3....then press enter In
my line from above it would now look like this:

kernel /vmlinuz-2.4.20-18.9smp ro root=LABEL=/ 3

5. press b to boot.

You should end up at a character based login...login as the root user, using
the password you supplied in the installation.
------------------------------------
Once logged in, edit the file /etc/X11/XF86Config ... if you don't have a
console based editor that you normally use, I recommend you first try nano
... see instructions above ... to edit with nano, issue the following
command:

nano -w /etc/X11/XF86Config

Use the Arrow Keys to find the video card section ... in RedHat 9, that
section should look similar to this:
CODE

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "NVIDIA GeForce 2 MX (generic)"
VideoRam 65536
EndSection



Change the driver line to:

Driver "nv"

(nv should be the standard driver for Nvidia Cards)

then use Ctrl-o to write the file ... then Ctrl-x to exit ...

use the command reboot to restart the PC ...
-------------------------
Notes:

The RedHat installer has a test button to test the GUI display ... you
should always test the mode you want to boot to during the install....

As a general rule ... I never set my installs to boot to graphical mode, but
to boot to text mode. For the first boot, log in as root in text mode. Then
type startx ... if you have problems, use the keys Alt-Ctrl-Backspace to
exit X-windows and then edit the /etc/X11/XF86Config file ... make
adjustments ... and when it's right, then edit the file (for RedHat)
/etc/inittab and find the runlevel line:

id:3:initdefault:

and change the 3 to a 5 to boot to runlevel 5 (graphical mode)....actually,
I never boot to runlevel 5 ... I just login as who I want and type startx...
Go to the top of the page
 
+Quote Post

Posts in this topic
- cagey cretin   Please Help; Monitor Disappears   Sep 9 2003, 11:19 PM
- - kk19115   I feel your pain. In fact I just recently posted ...   Sep 9 2003, 11:53 PM
- - cagey cretin   What a treat, eh? I had posted this problem on an...   Sep 10 2003, 06:28 AM
- - Joey   Can you give us a little more details on the type ...   Sep 10 2003, 06:58 AM
- - cagey cretin   Thank you helping Joey. Diplsay Adapter: Radeon ...   Sep 10 2003, 07:21 AM
- - Joey   When linux loads and the monitor goes dead try hol...   Sep 10 2003, 09:02 AM
- - kk19115   I'm running AMD 850 NVIDIA GForce FX 5200. I ...   Sep 10 2003, 10:26 AM
- - cagey cretin   QUOTE (Joey @ Sep 10 2003, 09:02 AM)When linu...   Sep 10 2003, 02:06 PM
- - Joey   If nano isnt installed try pico or vi Do you have...   Sep 10 2003, 02:34 PM
- - kk19115   My question to you cagey, is when you reinstalled,...   Sep 10 2003, 02:35 PM
- - cagey cretin   kk19115, both my monitor and video card were found...   Sep 10 2003, 02:44 PM
- - Hemant   assuming u have tried..Redhat-9.0... what installa...   Sep 11 2003, 02:18 AM
- - hughesjr   QUOTE Diplsay Adapter: Radeon What type of Radeon...   Sep 11 2003, 12:10 PM
- - hughesjr   kernel X.XX.XXXsmp ro root=LABEL=/ hdb=ide-scsi T...   Sep 11 2003, 12:23 PM
- - cagey cretin   Thank you all, everyone one of you, for chiming in...   Sep 11 2003, 10:14 PM
- - hughesjr   you can go to the file /boot/grub/menu.lst and edi...   Sep 11 2003, 10:58 PM
- - mode_flux   Hi, I'm having the same problem myself. I tri...   Sep 11 2003, 11:45 PM
- - cagey cretin   QUOTE (hughesjr @ Sep 11 2003, 10:58 PM)you c...   Sep 12 2003, 12:30 PM
- - azAZO9   Nice surprise about this shorter form. Can you tel...   Jul 13 2013, 05:58 AM
- - michaelk   azAZO9, If this is a legitimate post this is a lon...   Jul 13 2013, 10:33 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 02:22 AM