Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Usb Modem Problem, specifically, a Metricom USB modem
cfalcon
post Sep 5 2003, 02:53 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 5
Joined: 5-September 03
Member No.: 1,384



The Metricom wireless modem is my fastest internet connection, but I can't get Linux (I'm running Redhat 9) to work with it. As near as I can tell, it's supposed to just sort of work out of the box or something (the hardware browser shows it as a Metricom GS, which it is, but it doesn't give me a device path: I don't know whether this behavior is normal or what).

It's supposed to behave like a regular USB modem. I don't really know what that entails. I tried to configure it like my regular modem (except with device path /dev/input/ttyACM0 (a guess) instead of the sttys4 that my PCI modem uses), but it doesn't log on.

What happens: When I click "activate" on my GUI "Network Configuration" panel, the "activating" box pops up... and stays up. After some time, it will usually give me an "error 8", claiming it can't connect. Other times it just sits there until I close the "activating" box, then it hopefully gives me my error. Otherwise its state will change to "Active", forcing me to Deactivate it. If I try any of the other ACMs (1, 2, or 3), it gives me an "error 7", and it happens immediately. I haven't the foggiest what those mean, but I suspect that, since the modem is on only one of them (I think), that the one that acts different must be the correct choice. The modem doesn't make any noise or provide any feedback (except when it forms a PPP connection, the light changes from flashing green to yellow, but I haven't seen that in Linux yet).

Exact error:

"
redhat-config-network:

Cannot activate network device ppp0!

Failed to activate ppp0 with error 8
"

If I have the "Network Configuration" panel open (I mostly work through the GUI- if I have to edit a file that's fine, but I don't really know which ones to hit), the "devices" tab will let me choose between my regular modem and Ricochet (which is ppp0). The phone number is 3333, and in Windows you aren't supposed to put in a username and password- I've tried it with none and with bogus text, same result.

Under the "Hardware" tab, I can select the modem (called modem1, the regular dialup being modem0): as I said, I have it pointing to ACM0, and the baud rate is at 460800. I have tried with both no flow control and hardware flow control (one of the pages I link to implies that hardware is the way to go).


This seems to be the primary source for info about this topic: http://phobos.illtel.denver.co.us/~abelits/metricom/

This one seems to be pretty new, and the linx to the last article: http://www.linuxgazette.com/issue61/nielsen.html

This has a transcript from when Ricochet was friendlier (and had different rules, like the 777 dialup number instead of 3333: I think it's pretty old): http://lists.svlug.org/archives/svlug/1999...rch/012962.html

This covers the serial case, but I need USB: http://www.rightsock.com/~kjw/Tech/pppd-ww...c-ricochet.html

Anyway, that's the most helpful stuff I've found. Anyone see an obvious step I'm missing? Still pretty new to Linux, so I could have missed something really easy.

Thanks a whole lot.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th December 2017 - 03:17 AM