Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Access From Windows Desktop, How To?
cmt-kcmo
post Sep 4 2003, 05:48 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-September 03
Member No.: 1,382



I installed Linux 9.0 that I downloaded from Redhat. After finally getting it installed correctly, I can see my local network and can even access the Windows workstations, but I cannot see the Linux server from any Windows workstation. I created users so they have a home folder and want them to be able to store things there. Any ideas?

Thanks,

cmt-kcmo
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 4 2003, 08:54 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Create a linux user and give them a password that is the same as on the Windows network.

Do you have a Windows NT, 2000, or 2003 server as a domain controller? Do you have a WINS server?

If yes to both, try this in smb.conf:

First in the [Global] section
workgroup = windows workgroup name
security = server
password server = Domain Controler Name
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
wins server = IP Address of WINS server

If you don't have a WINS server or Domain Controller, then try this in [Global] section ....
workgroup = windows workgroup name
security = user
#password server =
encrypt passwords = yes
smb passwd file = /etc/samba/smbpasswd
#wins server =
----------------------------
If you don't already have a [Homes] section in the smb.conf file, then Create one buy going to bottom of the file and adding the line [Homes] ... if you have a [Homes] remark out the current lines and then add these under the [Homes] section:

[Homes]
comment = %U's Home Directory
browseable = no
writeable = yes
create mode = 0664
directory mode = 0775
-----------------------------
In the /etc/samba directory, create (or edit) the smbusers file and add a line for every windows users ... for example if you have a user named joey, then add a line like this:

joey=joey
---------------------------

Restart smb (/etc/init.d/smb restart) ...

go to your windows machine and try to connect to the Linux server.... if the Windows user is a valid Linux user, you should see a directory with the username under the linux server in Windows explorer...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
cmt-kcmo
post Sep 17 2003, 12:51 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-September 03
Member No.: 1,382



I have been able to find all theses files, but whenever I try to edit them, it says it is read only. Is there a special way or editor I should be using?

Thanks
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 17 2003, 01:20 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



No special editor, but you might need to be root.

If root can't edit the file either, then for each file you can't edit, issue the following command (as root):

chmod 644 filename


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
das7282
post Sep 27 2003, 01:36 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 21-September 03
Member No.: 1,486



To hughesjr

Ok, I've tried all the changes you said to make in the smb.config file and it has worked somewhat. The problem is, in Network Place (in Windows XP) I can see my Red Hat Linux system but it shows up as "<server string name>(localhost)" (<server string name> meaning I changed "server string =" in smb.config to reflect what I wanted the system to show up as other than "Samba Server").

The problem is when I try to access it in Windows I get the error message "localhost is not accessible. You might not have permission to use this network resource...." and then a second line says, "You were not connected because a duplicate name exists on the network..."

First, all of my computer on my network have unique names and none of then are named "localhost". But I also know IIS uses the name "localhost" to access the "wwwroot" folder. But I don't have IIS running on any of my computers. But just to make sure I decided to change the host name of my Linux system. So I edited my "/etc/sysconfig/network" file to reflect the host name I wanted. And then I had to edit the "/etc/hosts" file as well to add that host name (Red Hat told me to edit that one).

Now I have another problem...

I now have a "<server string name>(my new host name)" in Network place. But now when I try to access it, it just asks me for a user name and password. When I enter my local account's user name and password, nothing happens and it asks me for it again. What do I (still) need to do to be able to access it?

Any help on this would be greatly appreciated. smile.gif

Below are the settings I have in the files I have mentioned here...

"/etc/sysconfig/network"
[quote]NETWORKING=yes
HOSTNAME=My Choosen Name[/quote]
"/etc/hosts"
[quote]# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1  My Choosen Name[/quote]
"/etc/samba/smb.config" (Sorry it's so long but I wasn't sure what to leave out.)
[quote]======================= Global Settings =====================================
[global]

  workgroup = My Workgroup Name
  server string = My Choosen Name

;  hosts allow = 192.168.1. 192.168.2. 127.

  printcap name = /etc/printcap
  load printers = yes

  printing = cups

;  guest account = pcguest

  log file = /var/log/samba/%m.log

  max log size = 0

  security = user

;  password server = <NT-Server-Name>

;  password level = 8
;  username level = 8

  encrypt passwords = yes
  smb passwd file = /etc/samba/smbpasswd

;  ssl CA certFile = /usr/share/ssl/certs/ca-bundle.crt

  unix password sync = Yes
  passwd program = /usr/bin/passwd %u
  passwd chat = *New*password* %nn *Retype*new*password* %nn *passwd:*all*authentication*tokens*updated*successfully*


  pam password change = yes

;  username map = /etc/samba/smbusers

;  include = /etc/samba/smb.conf.%m


  obey pam restrictions = yes

  socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

;  interfaces = 192.168.12.2/24 192.168.13.2/24

;  remote browse sync = 192.168.3.25 192.168.5.255
;  remote announce = 192.168.1.255 192.168.2.44

;  local master = no

;  os level = 33

;  domain master = yes

;  preferred master = yes

;  domain logons = yes

;  logon script = %m.bat
;  logon script = %U.bat

;  logon path = %LProfiles%U

;  wins support = yes

;  wins proxy = yes

  dns proxy = no

;  preserve case = no
;  short preserve case = no
;  default case = lower
;  case sensitive = no

#============================ Share Definitions ==============================
[homes]
  comment = %U's Home Directory
  browseable = no
  writable = yes
  valid users = %S
  create mode = 0664
  directory mode = 0775
; map to guest = bad user


; [netlogon]
;  comment = Network Logon Service
;  path = /usr/local/samba/lib/netlogon
;  guest ok = yes
;  writable = no
;  share modes = no

;[Profiles]
;    path = /usr/local/samba/profiles
;    browseable = no
;    guest ok = yes


[printers]
  comment = All Printers
  path = /var/spool/samba
  browseable = no
  guest ok = no
  writable = no
  printable = yes

;[tmp]
;  comment = Temporary file space
;  path = /tmp
;  read only = no
;  public = yes

;[public]
;  comment = Public Stuff
;  path = /home/samba
;  public = yes
;  writable = yes
;  printable = no
;  write list = @staff

;[fredsprn]
;  comment = Fred's Printer
;  valid users = fred
;  path = /home/fred
;  printer = freds_printer
;  public = no
;  writable = no
;  printable = yes

;[fredsdir]
;  comment = Fred's Service
;  path = /usr/somewhere/private
;  valid users = fred
;  public = no
;  writable = yes
;  printable = no

;[pchome]
;  comment = PC Directories
;  path = /usr/local/pc/%m
;  public = no
;  writable = yes

;[public]
;  path = /usr/somewhere/else/public
;  public = yes
;  only guest = yes
;  writable = yes
;  printable = no

;[myshare]
;  comment = Mary's and Fred's stuff
;  path = /usr/somewhere/shared
;  valid users = mary fred
;  public = no
;  writable = yes
;  printable = no
;  create mask = 0765
[/quote]
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 27 2003, 06:16 AM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You need to have a user account on the Linux Machine that is the same username (and password) as the user on your windows machine.

The first problem you had is that all machines know localhost as themselves ... with an IP address of 127.0.0.1 ... so there was no connection made to the linux machine ... the windows machine tried to connect to itself.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 09:12 PM