Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Networking No Go For 2.6.0-test4, Networking Not Working
Brender
post Sep 2 2003, 12:27 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 2-September 03
Member No.: 1,363



Hello,

I'm fairly new to Linux still, learning more every day. Having a problem right now after compiliing a 2.6.0-test4 kernel. Networking doesn't work. I'm using Mandrake 9.1.

I've got a Realtek ethernet card, using 8139too. I've tried compiling it in and having it as a module, and I always get the same error:

Sep 1 21:58:34 localhost network: Setting network parameters: succeeded
Sep 1 21:58:34 localhost ifup: arping: socket: Address family not supported by protocol
Sep 1 21:58:34 localhost ifup: Error, some other host already uses address 127.0.0.1.

It's frustrating, because everything else in 2.6 works perfectly. Feels more responsive, and it's certainly a lot leaner than the installed Mandrake kernel.

I've looked up the error, all the remedies I've seen haven't worked for me. I do also get a bunch of modprobe errors when I boot into 2.6, but not when I boot 2.4. Possibly just things to take out of the modules.conf when I get it all working?

af_packet support is in as a module, I've tried it compiled in as well. Doesn't help! I haven't assigned anything to 127.0.0.1 other than localhost in the hosts file too.

Can anybody help me please?

Brender
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 2 2003, 06:02 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



The errors are caused because a newer version of module-init-tools is required to be installed for modules to work with a 2.6.x Kernel.

Here is a writeup for the modules problem:

Modules.
~~~~~~~~
- The in-kernel module loader got reimplemented.
- You need replacement module utilities from
http://www.kernel.org/pub/linux/kernel/peo.../rusty/modules/
- A backwards compatible set of module utilities is also available from the same URL in RPM format.
- Debian sid users can 'apt-get install module-init-tools'
- Modules now free stuff marked with __init or __initdata.
- For Red Hat users, there's another pitfall in "/etc/rc.sysinit". During startup, the script sets up the binary used to dynamically load modules stored at "/proc/sys/kernel/modprobe". The initscript looks for "/proc/ksyms", but since it doesn't exist in 2.5 kernels, the binary used is "/sbin/true" instead.

This, eventually, will keep modules from working. Red Hat users will have to patch the "/etc/rc.sysinit" script to set "/proc/sys/kernel/modprobe" to "/sbin/modprobe", even when "/proc/ksyms" doesn't exist.


You can download the Mandrake RPM from here for module-init-tools:
module-init-tools


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 11:31 PM