Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Need To Revert To Glibc 2.2, How to go back to GLIBC 2.2 (RH AS 2.1)
uescjp
post Aug 29 2003, 01:47 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-August 03
Member No.: 1,350



We installed GLIBC 2.3 on our RH AS 2.1 system in error. We are now receiving an error line on our printer (whenever we print a file), that says - "Incorrectly built binary which accesses errno, h_errno or _res directly. Needs to be fixed." This is the only symptom we are receiving, but Red Hat says they only support GLIBC 2.2. We tried to force the reinstall of 2.2 using RPM, but since we have a version number greater already installed, it refused. Is there a way to get back to GLIBC 2.2 without completely reinstalling Linux? Can we find out what program is creating the error and fix it? We have all our applications and data loaded on this box ready to go live - a reinstall would be very unhealthy (for our jobs). We need some ideas. Thanks!
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 29 2003, 02:11 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Are you sure that glibc is the only thing upgraded?

You can use the command:

rpm -e --nodeps glibc

to remove the glibc 2.3

then use:

rpm -Uvh glibc-xxxxx-.rpm ... but if other things are also installed at values higher than required by glibc 2.2 then you may get errors and no install....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
uescjp
post Sep 2 2003, 08:38 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-August 03
Member No.: 1,350



We were told by Red Hat that removing GLBIC would create an unstable system that may not be bootable. We cannot afford to destroy this box since we are so close to going live. We did not install any other upgrades. Red Hat says that GLIBC ver. 2.3 is not supported in their Advanced Server 2.1 - so we assume this version is causing the problem.
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 2 2003, 03:03 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



not having a glibc WILL make a box not bootable, that is for sure .... but you will be re-installing the correct glibc.

You can FIRST run the command:

rpm -q --filesbypkg glibc

Which will tell you every file installed by that package ... so you can back them up and replace them later if you want.


You can try the command:

rpm -Uvh --replacepkgs --replacefiles --oldpackage --test glibc-xxxx.rpm

The above command won't actually do the upgrade ... it will just report about what it would do.... then remove the --test if it says it will run.

This should upgrade the package and replace all the glibc 2.3 files with the glibc 2.2 files...

What each of the switches mean are as follows:
--replacefiles
Install the packages even if they replace files from other,
already installed, packages.

--replacepkgs
Install the packages even if some of them are already installed
on this system.

--oldpackage
Allow an upgrade to replace a newer package with an older one.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
uescjp
post Sep 3 2003, 11:00 AM
Post #5


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-August 03
Member No.: 1,350



Apparantly another package was updated that is dependent on GLIBC 2.3. This is the message I get when I try to force an update to GLIBC 2.2 -
Failed dependencies:
libc.so.6(GLIBC_2.3) is needed by binutils-2.13.90.0.18-9

Can I remove binutils also and install the older version? If so, in what order? glibc then binutils, or binutils first? Or am I really screwed?
Go to the top of the page
 
+Quote Post
hughesjr
post Sep 3 2003, 05:13 PM
Post #6


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



In looking at the RedHat website for 2.1 Advanced Server (i386), I get these as the most current versions:

glibc-2.2.4-32.8.rpm
binutils-2.11.90.0.8-12.rpm

I would recommend that you check all your actually installed files agianst this list:

2.1AS I386 Original install:
ftp://ftp.redhat.com/pub/redhat/linux/ent...n/os/i386/SRPMS

updates since release:
ftp://ftp.redhat.com/pub/redhat/linux/upd...1AS/en/os/SRPMS
-----------------------
If the only things that are wrong are the glibc and binutils, then you can do this to fix it:

obtain glibc-2.2.4-32.8.rpm and binutils-2.11.90.0.8-12.rpm and put those files in a temporary directory and go to that directory... test the install using this command:

rpm -Uvh --replacepkgs --replacefiles --oldpackage --test glibc-2.2.4-32.8.rpm binutils-2.11.90.0.8-12.rpm

(the above command is all on one line ...) ... if no errors, remove the --test and try....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
uescjp
post Sep 4 2003, 03:14 PM
Post #7


Whats this Lie-nix Thing?
*

Group: Members
Posts: 4
Joined: 29-August 03
Member No.: 1,350



The suggestions worked! However, I had to add the --nodeps switch to the rpm command to allow the binutils to reinstall. A query of the installed packages now reports the correct versions. Thanks for your help!!
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 12:34 AM