Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Problem With Glib, problem with GLib
naveedbs
post Aug 27 2003, 04:23 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 27-August 03
Member No.: 1,333



I sucessfully installed glib-2.2.0 from source
but getting error when i install some software dependent on glib ...
Im using Red Hat Linux 7.3. i need some software (XChat) which requires me to
install GLib >= 2.0.2. so i downloded the latest version from www.gtk.org
(2.2.0) and begin installation process. I did the following:
1: installed GLib via
#./configure
#make
#make install
2: put a line in /etc/ld.so.conf
3: run /sbin/ldconfig
Everyrthing seems OK, but when i try to install atk-1.0.3 from source i get
the error:
"*** 'pkg-config --modversion glib-2.0' returned 2.2.0, but GLIB (2.0.1)
*** was found! If pkg-config was correct, then it is best
*** to remove the old version of GLib. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH
*** to point to the correct configuration files"

I set LD_LIBRARY_PATH, and PKG_CONFIG_PATH as
#export LD_LIBRARY_PATH=/usr/local/lib
#export PKG_CONFIG_PATH=/usr/local/glib-2.2.0
Im still getting the same erorr. I uninstall the old GLib via
# rpm -e --nodeps glib
#rpm -e -no --deps glib-devel
and delete all glib specific modules / executables from /usr/bin. But still
getting the same error!!! :S

...Sometimes I can run the configure script (in case of pango-1.0.5 not
atk-1.0.3). But Then I have make error.

Im using KDE 3.0 not GNOME...
I dont want to install glib via RPM because it requires me to install lots of
other RPMs...

when it didnt work, i also built GLib RPM via checkinstall and install it but
still getting the same error (RPM installed successfully problem is with GLib
Dependent Software)...

Please help me solve my problem...

thanks in advance...

PS: I dont use apt-get as ftp.freshrpm.net does not response to my domain, i
suppose...
Go to the top of the page
 
+Quote Post
fobius
post Aug 27 2003, 06:16 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 27-August 03
Member No.: 1,334



I'm having some similar problems. I'm running Mandrake 9.1 and right now I'm trying to install gtk+ and all its dependencies by source. Right now I'm trying to install glib 2.2.0, atk 1.2.0 and pango 1.2.0. and I'm having trouble.

glib seemed to have installed correctly but when i run testglib i get these messages:

** (process:7042): WARNING **: harmless warning with parameters: 42 Boo 0x3039
** Message: the next warning is a test:

(process:7042): GLib-CRITICAL **: file gmessages.c: line 804 (g_print): assertion `format != NULL' failed

I'm not sure how to fix these, I think one error message is part of the test but not sure which one.

For atk, assuming that those glib messages were ok, I've run configure in the atk directory (in /usr/local) and then I've tried to run make. I then get this weird message:

/bin/sh: line 1: /usr/local/atk-1.2.0/atk/..//usr/local/glib-2.2.0/gobject/glib-genmarshal: No such file or directory
make[2]: *** [stamp-atkmarshal.c] Error 127
make[2]: Leaving directory `/usr/local/atk-1.2.0/atk'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/usr/local/atk-1.2.0'
make: *** [all-recursive-am] Error 2

I've entered /usr/local/glib-2.2.0 in etc/ld.so.conf and run ldconfig as root in the glib directory. However, the atk makefile somehow can't detect that glib-genmarshal exists.

I've tried setting the PKG_CONFIG_PATH to include /usr/local/glib-2.2.0 but that doesn't seem to work either.

Any ideas?
Go to the top of the page
 
+Quote Post
Joey
post Aug 27 2003, 06:26 PM
Post #3


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Why dont you just install newer rpms?
Go to the top of the page
 
+Quote Post
fobius
post Aug 27 2003, 11:40 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 27-August 03
Member No.: 1,334



I've tried installing with rpms but there seems to be problems with my linux. when i use rpm -q to search for the packages, it says that it is not installed. I then use rpm -Ui and it says it already is installed. is this because that i tried installing from source?
Go to the top of the page
 
+Quote Post
Joey
post Aug 28 2003, 06:55 AM
Post #5


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Exactly what files did you download/try to install?

Are you trying to install a new version of Xchat? I believe there is a RPM version that ships with Red Hat 7.3
Go to the top of the page
 
+Quote Post
fobius
post Aug 29 2003, 12:12 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 27-August 03
Member No.: 1,334



Just the need packages for gtk, such as atk 1.2.0, pango and glib 2.2.0. Any idea why the rpm's aren't working? Why the error when compiling from source?
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 29 2003, 06:03 AM
Post #7


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



I use Redhat 9 and sometimes when I have problems compiling items, I try the compatibilty compiller (on my current install it is gcc296) ....

btw, the domain for apt-get is freshrpms.net not freshrpm.net.

I would install the packages with all the dependancies .... they wouldn't be dependancies if they weren't required....(just my opinion)


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 12:25 AM