Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Cannot Access Port 80
arizona
post Aug 24 2003, 06:07 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 24-August 03
Member No.: 1,313



I have a Dell 500SC running Suse Linux 8.2. I am attempting to use this machine as a simple web server. The web server is Abyss X1. When I try to configure the web server to listen on Port 80 it comes back and says that this port is already in use.

I have tested the web server by using port 8080 and trying the web site IP with the port appended to the name (xx.xx.xx.xxx:8080) and this works fine. I can't use it this way though as I must allow other users to access the website using our domain name (also works with the :8080 at the end).

I have spent hours on the SuSe web site and on search engines trying to fix this problem. I know that this is a Linux issue as I just had the same web site operational using three other boxes (an old Mac using MacOS 8.5 and Mac fttp, an eMac using OS X and Apache and a windows XP box using Abyss). Our Internet service supplier does not block port 80.

I am about ready to throw in the towel on Linux and go back to Windows or the Mac OS. I try Linux every six months or so and find it continually frustrating, inaccessable and hard to get clear and direct support on. Can anyone help before I take the software and toss into the can?
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 24 2003, 08:23 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



type the command:

netstat -an | grep LISTEN | grep -v STREAM

to see if you have a process running on port 80 already.

If you see this:

tcp 0 0 0.0.0.0:80 0.0.0.0:* LISTEN

then you already have something listening on port 80 ... it is probably either apache httpd(most likely) or TUX.

You can do the command:

ps -ef | grep httpd

to see if Apache httpd is running ... if it is you will get several processes that look like this:

apache 2237 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2238 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2239 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2240 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2241 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2242 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2243 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd
apache 2244 2234 0 20:18 ? 00:00:00 /usr/sbin/httpd

if httpd is running, issue this command to stop it:

/etc/init.d/httpd stop

and if it starts automatically at boot time, issue this command to remove it:

chkconfig --del httpd

If SUSE doesn't use chkconfig, then just go to /etc/rc0.d , /etc/rc1.d, /etc/rc2.d, /etc/rc3.d, /etc/rc4.d, /etc/rc5.d, and /etc/rc6.d ... and in each directory remove the files K??httpd and/or S??httpd (where ?? is a number). This will prevent httpd from starting and stopping at PC startup and shutdown time.


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post
arizona
post Aug 25 2003, 09:21 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 24-August 03
Member No.: 1,313



I have done the first few steps that you mention and this is what I get:

tcp 0 0 0.0.0.0:9999 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:8080 0.0.0.0:* LISTEN
tcp 0 0 0.0.0.0:6000 0.0.0.0:* LISTEN
tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN
tcp 0 0 :::ZZ :::* LISTEN

The Abyss server, as I have already mentioned, is on port 8080. Apache is not running.
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 25 2003, 01:10 PM
Post #4


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



This means:
QUOTE
When I try to configure the web server to listen on Port 80 it comes back and says that this port is already in use.
That your server is listening on port 80 ... and that the new web server can't listen on port 80.

If the ISP were to block port 80, it wouldn't prevent the web server from starting ... but it would prevent external traffic from making it to the webserver.

Another thing that can block low ports (below 1024) and allow high port connections is a firewall ... the default firewall for SUSE is iptables ...

Type the command:

iptables -L

If you get these results:

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination

Chain INPUT (policy ACCEPT)
target prot opt source destination


Then you have iptables enabled in the kernel, but no rules ... if you get something like this:


ACCEPT tcp -- anywhere anywhere tcp dpt:ssh flags:SYN,RST,ACK/SYN
REJECT tcp -- anywhere anywhere tcp dpts:0:1023 flags:SYN,RST,ACK/SYN reject-with icmp-port-unreachable
REJECT udp -- anywhere anywhere udp dpts:0:1023 reject-with icmp-port-unreachable


Then you have some rules set....you will need to open port 80 in from everywhere ... and if you also want https, you will need to open port 443 in....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 14th December 2017 - 05:18 AM