Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> /usr/bin/ld: Cannot Find -lusb Error? Help?, mandrake 9.1 adsl usb modem headaches
Hyp007
post Aug 20 2003, 03:13 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 20-August 03
Member No.: 1,292



Hi

No one has been able to help me with this problem and I mean know one lol I have asked hundreds of so called linux experts, and none have given a solution that worked.

I am having no luck at all installing my adsl modems, either one.
I had decided to give l
Linux another go because people were swearing blind to me that it was getting a lot better, but it seems every time I try it again, no matter the distro, I always end up with an unfixable problem that I canít solve. It simply scares me away, why does it have to be so hard to operate? Itís supposed to be a system designed to make my life easier not more stressful?

Anyways I am after installing either my Zoom modem or my Copperjet allied data 800 one, both adsl usb modems.

With the copperjet one I managed to get hold of a driver for it from sourceforge, and it looked to be the promising of the two for a success, but I am getting the following error when I do a, make

cc -I../lib/libusb -c common.c
cc -I../lib/libusb -lusb 5160.c common.o -o 5160
/usr/bin/ld: cannot find -lusb
collect2: ld returned 1 exit stats
make[1]:*** [5160] Error 1
make[1]:leaving dir the dir i was doing the make in
make:*** [911] error 2

Now I had a look around through google doing a search for, lusb, and found some forum posts relating to, usbutils, package, and it not being installed, so I checked and usbutils is installed on my machine,

So I am stumped, I have no clue what to do next??????????

Its so frustrating because I have the driver for the copperjet modem right here I just canít install it because of that dumb error above.

If its not asking for usbutils with lusb in it, then what the hell is , -lusb, and how can I get it on my system?

Or if its not asking for -lusb then what the hell is it asking for??????
Can anyone out there help me at all?? I am a n00b and have no clue what to do next at all???

I am using Mandrake 9.1
Hyperion out
Go to the top of the page
 
+Quote Post
Joey
post Aug 22 2003, 10:09 AM
Post #2


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Hi,

Did you try what they suggested at http://forums.devshed.com/t78084/s342fd081...421eae608a.html
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 11:16 PM