Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Redhat 9 Installation Problems... Nvidia Drivers
SabirIbrahim
post Aug 16 2003, 10:07 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 16-August 03
Member No.: 1,262



Hi,

I recently bought a Sony VAIO GRT170 notebook computer and I'm trying to install RedHat Linux 9 alongside Windows XP. I'm pretty sure the dual-booting works properly, since the GRUB bootloader comes up at startup like it's supposed to, but when I choose Linux, I get a blank screen (after all the intialization commands). From what I've read so far, I think this is because of the video card (NVIDIA GeForce4 FX Go 5600, 64MB); during installation, instead of leaving the generic VESA driver selected, stupid me went through the list and chose the one that most closely matched. My question is: how do I fix this without completely redoing the installation? I downloaded the updated Linux drivers from NVIDIA's website, but I have no idea what to do with them. Since I can't even really start Linux at all, I have no idea what to do. I'm a complete newbie, so step-by-steb help would be very much appreciated.

Thanks,

Sabir
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 16 2003, 05:41 PM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



You can boot to runlevel 3 (a character based startup) and then edit your /etc/XF86Config file to properly set the video information.

If you're not sure how to edit files in redhat character based mode, I recommend nano ... it was probably installed ... and it is fairly easy to use.

When you load nano it will have a menu with commands, they will look like this:

^G Get Help ^O WriteOut ^X Exit

The ^ means use the Ctrl key ... so Ctrl-o will open the write out (save the file) option then Ctrl-x will exit....

Here is how to boot to runlevel 3....
-------------------------------------------
1. Start the PC ... when you get to GRUB, press the e key to go to edit mode.
2. Find the Kernel line ... it will look something like this:

kernel /vmlinuz-2.4.20-18.9smp ro root=LABEL=/

3. Select this line using the Arrow Keys and with the line selected, press e to edit the line.

4. Move to the end of the line, and add a space and 3....then press enter In my line from above it would now look like this:

kernel /vmlinuz-2.4.20-18.9smp ro root=LABEL=/ 3

5. press b to boot.

You should end up at a character based login...login as the root user, using the password you supplied in the installation.
------------------------------------
Once logged in, edit the file /etc/X11/XF86Config ... if you don't have a console based editor that you normally use, I recommend you first try nano ... see instructions above ... to edit with nano, issue the following command:

nano -w /etc/X11/XF86Config

Use the Arrow Keys to find the video card section ... in RedHat 9, that section should look similar to this:
CODE
Section "Device"
       Identifier  "Videocard0"
       Driver      "nvidia"
       VendorName  "Videocard vendor"
       BoardName   "NVIDIA GeForce 2 MX (generic)"
       VideoRam    65536
EndSection


Change the driver line to:

Driver "nv"

(nv should be the standard driver for Nvidia Cards)

then use Ctrl-o to write the file ... then Ctrl-x to exit ...

use the command reboot to restart the PC ...
-------------------------
Notes:

The RedHat installer has a test button to test the GUI display ... you should always test the mode you want to boot to during the install....

As a general rule ... I never set my installs to boot to graphical mode, but to boot to text mode. For the first boot, log in as root in text mode. Then type startx ... if you have problems, use the keys Alt-Ctrl-Backspace to exit X-windows and then edit the /etc/X11/XF86Config file ... make adjustments ... and when it's right, then edit the file (for RedHat) /etc/inittab and find the runlevel line:

id:3:initdefault:

and change the 3 to a 5 to boot to runlevel 5 (graphical mode)....actually, I never boot to runlevel 5 ... I just login as who I want and type startx...


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th December 2017 - 03:14 AM