Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Close Lid & Suspend On T22, Suspend fails and closing lid on IBM t22
judall
post Aug 5 2003, 09:02 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 4-August 03
Member No.: 1,194



Another linux question - although this is more generic as it pertains to an IBM T22 laptop.

I have tried 3 different variants of Linux on this machine: Lindows, Redhat 9, and Mandrake 9.1. All exhibit different behaviour regarding suspend, but none of them are satisfactory.

It seems a universal behaviour of all of them that closing the lid will not force suspend. Although clearly something happens under the covers. Upon closing, the hard drive spins off, then immediately restarts, then spins off, then immediately restarts. I have tried chaning the BIOS settings for lid close behaviour with no affect on the results.

Of the three, the suspend action itself (when invoked purely by software) seems to work most reliably on Lindows. Mandrake has the hardest time. Running "apm --suspend" on mandrake result in bizarre LCD behaviour but ususally ends up in a suspended state. However, resuming is never a safe bet. It seems to come up, but the graphic desktop is usually very iffy. Sometimes it will not present itself for some time (resulting in a text only login screen for the better part of a minute). Other times it will present, but be in some wonky unusable apparent mode (320x240 - 8 bit colour?). But at other times, it will come back to life.

Redhat sometimes manages to suspend and sometimes just sits and hangs forever.

Any suggestions?

Jim
Go to the top of the page
 
+Quote Post
hughesjr
post Aug 6 2003, 11:39 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 3,433
Joined: 25-July 03
From: Corpus Chrsiti, TX, USA
Member No.: 1,151



Info :
http://www.cs.utexas.edu/users/walter/geek.../linux-t22.html
http://www.linuxcare.com/labs/certs/ibm/th.../T22/padt22.epl

Only minor issues after bios upgrades....


I would make sure to have the latest bios (at least 1.10 16ET30WW):
http://www-3.ibm.com/pc/support/site.wss/d...cid=MIGR-4VWPPU

looks like you have to have a working windows partition and system to do the bios upgrade....


--------------------
Johnny Hughes
hughesjr@linuxhelp.net
Enterprise Alternatives: CentOS, WhiteBoxEL
Favorite Workstation Distros (in order): CentOS, Gentoo, Debian Sarge, Ubuntu, Mandrake, FedoraCore, Slackware, SUSE
Favorite Server Distros (in order): CentOS, WhiteBoxEL, Debian Sarge, Slackware, Mandrake, FedoraCore, Gentoo, SUSE
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 23rd October 2017 - 10:33 AM