Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> Ultimate Newbie (gulp) --help!, Linux and Apache and Php and MySql Oh MY
Phydeaux
post Oct 17 2002, 03:13 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 16-October 02
Member No.: 58



I'm a one man shop - I hired a guy to learn linux, and develop MySql/CGI based website. Which he did. Unfortunately a big developor then hired him. I sort of feel like my money and my developer went to XXX. But now I need to maintain the website.

Anyway, recently shutdown offices and moved the computer to my home.

1. Apache load question:
How do I resolve a
"syntax error on line 30 of /etc/http/conf/httpd.conf

Cannot load /usr/modules/mod_vhost_alias.so into server: /usr/modules/mod_vhost_alias.so: cannot open shared object file: No such file or directory.

I'm quite sure this error is my fault. Since their were no DNS services enabled initially, my guess was that I needed to change the server name to an IP address on the new subnet.

I tried to do this using a combination of Comanche and manually changing the httpd.conf file. After the change, by the way, their is now an httpd.conf,v file. Insofar as I understand virtual hosting, I have not tried to enable it.

Silly me did not make a backup. (See next question).

2. What would be the easiest way to back up the harddrive to a win98 machine on same network? (Nervous working without a backup).

3. How do I make the Apache server visible on the same network segment, ie., all behind a linksys befsr41 router / Direct DSL gateway?

I've configured the Apache with a static private address (as shown below). I presume I have to:
a). Exclude that address from the befsr41 DHCP server.
cool.gif. Enable some sort of DNS server. (propose to do it on apache machine)
c). Enable DNS on the befsr router, which has 3 entries for DNS. Use the first entry for the local dns and then the latter 2 for the 2 provided by my dsl service provider.

4. When the web was up, (locally, not on internet) you could go to either the main page and view boats, or an administrative page where you could add boats to the database, do maintenance work etc. Looking around I found no index.htm, main.html, default.htm or welcome.htm files. However, typing some of the commands from the history log, the dbi program spits out errors - but also spits out html code.

If I load netscape (v4.72) , and go through the location bar - the "websites" listed are:

http://127.0.0.1/cgi_bin/customer_cgi
http://localhost/
http://localhost.localdomain/cgi_bin/customer_cgi
http://127.0.0.1/bg.jpg
http://127.0.0.1/index.html
http://192.168.0.250/
http://127.0.0.1/cgi_bin/boat_list.cgi
http://127.0.0.1/cgi_bin/control.cgi

However, doing a locate on cgi - I find no such cgi files. However, I don't know how much the webserver browser was used, and if it is indicative of typical pages. From recollection he was working in PHP and or Perl.

A search of the document root (/home/httpd/) yields three directories /icons /html and /cgi. The /html directory doesn't actually contain any html, only /index_files, which contains a bunch of icons and data.

The /cgi_bin is empty.

In /root there is /mysql /odbc and a file called boatdb (which was as I recall the name of the boat database).

in /var/lib/mysql are three directories
/boat /mysql and /test. /boat contain a variety of .frm .myd and and .myi files. /mysql contains more of the same, except they seem to have tables tblxxx.frm for example.

Were the pages generated from the database? I have no idea. Any assistance in determine how this thing should run, and/or whether it might run again would be vastly appreciated.

Miscellaneous info:

Office (Old) Home
network 192.168.0.x 192.168.1.y
Linux machine 192.168.0.250 192.168.1.11
Name server 192.168.0.5 ?? ??
host(netconf) localhost.localdomain
workgroup=home
linux1.workgroup
apache ver 1.3.12-2
Linux Redhat 6.?
Desktop Gnome/kde


Httpd.conf settings:
ServerType standalone
Port 80
HostNameLookups off
User nobody
Group nobody
Serveradmin root@localhost (yes I know this is wrong)
ServerRoot "/etc/htppd/"
#BindAddress 192.168.0.250 (org no #, then I changed to 192.168.1.11 server stopped working, set back did
(not fix, returned to 0.250, did not fix, # did not fix)
ErrorLog /var/log/htppd/error_log
.
.
CustomLog /var/log/httpd/access_log
PID /var/run/httpd.pid
Scoreboardfile /var/run/httpd.scoreboard
LockFile /var/lock/httpd.lock
ServerName localhost.localdomain (original value, also tried 192.168.1.11)
TimeOut 300
KeepAlive on
.
.
Now there are a variet of settings that follow - however, no uncommencted listens or virtual hosts.
Now, I tried commenting the first three lines of the modules that are loaded list to prevent them from loading as they seem to all be virtual host related. Essentially the same error message occurs for each module in the list.

Thanks for the help!

Chris
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
Phydeaux
post Oct 19 2002, 01:53 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 16-October 02
Member No.: 58



QUOTE (joey @ Oct 17 2002, 04:01 PM)
Hi Chris,

Let's deal with one question/problem at a time.

For your apache issues, what exactly is on line 30 of your httpd.conf file?

Can you please paste the whole conf file into the forum so I can have a look.

For question 3 "How do I make the Apache server visible on the same network segment, ie., all behind a linksys befsr41 router / Direct DSL gateway?"

Once you have apache running, assuming there is no firewall on the machine, all other machines on your local network should be able to get it without a problem.

Yes it sounds like your pages are being generated from the database.

Anyhow, let me know the answers to my questions above and we will take things from there.

Thanks Joe

Line 30 is the first uncommented module. And if I comment it .. it bombs on the next, comment it.. bombs on the next.

Thanks!

Chris
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 06:21 PM