Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Chmod Problems...
LinuxHatesMe
post Jun 24 2003, 10:13 AM
Post #1


./configure
***

Group: Members
Posts: 65
Joined: 21-June 03
Member No.: 996



After messing around with help files and commands and after trying to cd to this /mnt/win_d partition in command prompt and getting permission denied I came to the conclusion that perhaps my permissions aren't correct. ls -l in the mount folder shows me that it gives the group and other users read access. So I su into root and do chmod 775 /dev/hda5/ where hda5 is the device for the windows partition I'm trying to access. After doing this and doing ls -l again in the /mnt folder I find that it didn't change these permissions. Hrm... am I doing something wrong? Am I forgetting to do something? Or perhaps these changes aren't immediate unless I perform anotehr command afterwards? Even so, why am I getting permission denied EVEN THOUGH all users should have read access, at least?!
Go to the top of the page
 
+Quote Post
Joey
post Jun 24 2003, 10:14 AM
Post #2


LinuxHelp Admin
*******

Group: Admin
Posts: 1,096
Joined: 18-September 02
Member No.: 1



Can you mount it as root?
Go to the top of the page
 
+Quote Post
chrisw
post Jun 24 2003, 11:42 AM
Post #3


RMS is my Hero
******

Group: Admin
Posts: 634
Joined: 27-September 02
From: Louisiana
Member No.: 5



i have this problem with my external zip disk
i mount it under /mnt as zip250.0

the permissions are root:root rwxr_xr_x i think...not in front of my server at this moment....

for some reason i tried to change permissions to 0700 but it wont let me...i dont understand why it does this
im even root while trying to change the permissions
might be a fstab thing..might not...

but if you are trying to mount your windows partitions and its ntfs...
you have to patch the kernel to add ntfs support...plus i dont think it will allow you to change
the permissions to write to the directory because it is rather DANGEROUS to write to a ntfs
partition while in linux....


--------------------

Chris W.
Go to the top of the page
 
+Quote Post
LinuxHatesMe
post Jun 24 2003, 12:02 PM
Post #4


./configure
***

Group: Members
Posts: 65
Joined: 21-June 03
Member No.: 996



My machine auto mounts them.. I can su into root and access them NO problem. But when I exit out and login as my user he can't do diddly squat. Makes no sense why chmod doesn't work AS root. I tried adding ALL permissions to this directory just for the hell of it and they still didn't change for shit. No my system is fat32 ONLY. I refuse to use ntfs file systems.
Go to the top of the page
 
+Quote Post
michaelk
post Jun 24 2003, 01:55 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,796
Joined: 23-January 03
Member No.: 360



chmod does not work with vfat partitions.

To allow users to read / write vfat partitions in linux change your /etc/fstab file

/dev/hda5 /mnt/???? vfat user,umask=000 0 0

For zip since you do not want to mount on boot

/dev/sda4 /mnt/???? vfat noauto,user, umask=000 0 0

Change /mnt/???? to match your mount points.

See man pages for mount & fstab for additional help with options.

BTW here are two sites that you can search for addition help with your problems
www.justlinux.com
www.linuxquestions.org
Go to the top of the page
 
+Quote Post
LinuxHatesMe
post Jun 24 2003, 02:13 PM
Post #6


./configure
***

Group: Members
Posts: 65
Joined: 21-June 03
Member No.: 996



Stupid chmod.. it made me think I was going crazy. For a time I had thought perhaps I wasn't typing it wrong and had retyped it over and over. Thanx for informing me of chmod and vfat conflictions. I'll look into that and hopefully get it working.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th October 2017 - 10:20 AM