Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> No Lan After New 2.4.21 Kernel Compile, no lan after new 2.4.21 kernel compile
grasshopper
post Jun 23 2003, 08:55 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 11-May 03
Member No.: 818



I am running debian gnu linux 3.0
I recently compiled a new kernel for my system (2.4.21), all seemed good until i noticed that i did not have lan functionality. I have on board lan (Realtek 8100B, support 10Mb/s and 100Mb/s operation).
It seems to me like the kernel didn't detect my lan or something? This seems puzzling since I just checked and I definitely compiled the kernel with lan support and tcp and all the obvious lan stuff...
If I run ifconfig with eth0 and an ip address, it gives me an error... something to the effect of eth0 can't find device (i can get the exact error msg if you need). Anybody have any ideas of what to try next to get my lan connection up and running again? Note: before I was running a 2.2.something kernel and lan worked just fine. Bizarre.
Go to the top of the page
 
+Quote Post
warheros
post Jun 23 2003, 10:10 PM
Post #2


./configure
***

Group: Members
Posts: 54
Joined: 20-June 03
Member No.: 991



you could always take the LAN stuff out of your previous kernel and replace what you have as the LAN stuff in your new kernel with it...? i dont know though besides that, just an idea.
Go to the top of the page
 
+Quote Post
Corey
post Jun 24 2003, 08:25 AM
Post #3


Its GNU/Linuxhelp.net
*******

Group: Admin
Posts: 1,254
Joined: 21-September 02
From: St John's, Newfoundland, Canada
Member No.: 3



First off, check to make sure you have the kernel module loaded with "lsmod". Chances are, it's not there. If you compiled the card into the kernel, then check the output of your dmesg to see if the network card was detected whatsoever. Otherwise, go back into your "make menuconfig" and go back to the networking device section, go to your kernel module (i'm not sure what it is for your device, i have a realtek, and mine is 8139too) and compile it as a module. Exit and save and run "make modules && make modules install". Then "modprobe -v 8139too" or whatever your module is. This should work, then you can just run "/etc/init.d/networking restart" to re-initialize your network. Run ifconfig -v to confirm.


--------------------
Corey Quilliam
(former) Linuxhelp.ca Administrator
cquilliam-AT-gmail-dot-com

Want to help out Linuxhelp.net? Check out our Linuxhelp Wiki and see if there are some articles you would like to submit!!

--
Ubuntu 8.04 64-bit - Work Laptop (HP-Compaq NC6400 Core2)
Kubuntu 8.04 64-bit - Desktop (HP m8120n QuadCore)
Ubuntu 6.04 - Server (I'm not upgrading this baby until support runs out in 2012) (Some old POS dell)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 17th December 2017 - 08:26 PM