Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> How to install a graphics card driver for Radeon HD 7550M/7570M/7650M?, How to install a graphics card driver and also get OpenCL working?
zedlinux
post Nov 16 2016, 05:48 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 28-September 16
Member No.: 19,146



So I am having a lot of difficulties getting a graphics driver working on my CentOS 6 running laptop. After I get that working I want to get it so that OpenCL can use the Radeon HD 7550M as device, but for now let's focus on getting the graphics card driver installed. Here is the history of what has happened:

A while ago I got an rpm for what I thought was a good graphics driver for my laptop, when it didn't work I gave up on it for a while and started working on something else (without a graphics card driver installed). Later I returned to the problem and what I thought was the problem was that simply hadn't initialized it via aticonfig. So I do aticonfig --initial --input=/etc/X11/xorg.conf. At first it seemed to work but then when I used to monitors this would happen: i imgur com lh4zHVi.jpg ...and when I do a print screen it looks like this: i imgur com 6UWPvfi.png (which is how it should look) so at least it thinks it's working fine.

I find the rpm I used for the driver and trying updating it; I get this which looks like it's already updated:

[root@minnow02 zack]# rpm -U -v -h /root/rpmbuild/RPMS/x86_64/fglrx64_p_i_c-15.302-1.x86_64.rpm
Preparing... ########################################### [100%]
package fglrx64_p_i_c-15.302-1.x86_64 is already installed

So I decided to uninstall and reinstall using a different rpm; when I did aticonfig --uninstall I got this:

[root@minnow02 zack]# sudo aticonfig --uninstall
prelink: /tmp/#prelink#.cxK9Gk: Recorded 2 dependencies, now seeing -1

prelink: Couldn't stat /usr/bin/aticonfig: Permission denied
prelink: /tmp/#prelink#.jqRTUs: Recorded 2 dependencies, now seeing -1

prelink: /usr/bin/atiode: Could not parse `/usr/bin/atiode: error while loading shared libraries: libGL.so.1: failed to map segment from shared object: Permission denied'
prelink: /usr/bin/atiode: at least one of file's dependencies has changed since prelinking
prelink: /tmp/#prelink#.n4fBCy: Recorded 8 dependencies, now seeing -1

prelink: /usr/bin/fgl_glxgears: Could not parse `/usr/bin/fgl_glxgears: error while loading shared libraries: libGL.so.1: failed to map segment from shared object: Permission denied'
prelink: /usr/bin/fgl_glxgears: at least one of file's dependencies has changed since prelinking
prelink: /usr/bin/fglrxinfo: Could not parse `/usr/bin/fglrxinfo: error while loading shared libraries: libGL.so.1: failed to map segment from shared object: Permission denied'
prelink: /usr/bin/fglrxinfo: at least one of file's dependencies has changed since prelinking
prelink: /usr/lib64/fglrx/fglrx-libGL.so.1.2: Could not parse `/usr/lib64/fglrx/fglrx-libGL.so.1.2: error while loading shared libraries: /usr/lib64/fglrx/fglrx-libGL.so.1.2: failed to map segment from shared object: Permission denied'
prelink: /tmp/#prelink#.U2NkxT: Recorded 6 dependencies, now seeing -1

prelink: /usr/sbin/atieventsd: Could not parse `/usr/sbin/atieventsd: error while loading shared libraries: libGL.so.1: failed to map segment from shared object: Permission denied'
prelink: /usr/sbin/atieventsd: at least one of file's dependencies has changed since prelinking
One or more files have been altered since installation.
Uninstall not completed. Please see /etc/ati/fglrx-uninstall.log for details.

But when I looked inside of the fglrx-uninstall.log I got this, which looks like a success?:

*** AMD Proprietary Driver Uninstall Log 2016-11-16 12:31:33 ***
Executing rpm -V --nodeps fglrx64_p_i_c-15.302-1.x86_64
.M....... /usr/bin/amd-console-helper
Executing rpm -e fglrx64_p_i_c-15.302-1.x86_64
Command result 0
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 12th December 2017 - 12:49 PM