Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Unable to install many distros HP Envy 15, Kernel Panics and ACPI errors
post Sep 27 2016, 05:38 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 27-September 16
Member No.: 19,143

I'm going to copy/paste from my reddit thread as all the details are already there. This is really frustrating! Add on to the list of Distros that are unbootable the latest Ubuntu with MATE desktop. Is there an alternative kernel I can try booting from? If so, how would I go about that?

Reddit post below ----

So this is a continuation of a previous thread where I thought the issue was solved but alas no. New thread because I've narrowed it down to ACPI/APIC The situation is that Fedora, Mint and OpenSuse all had issues with their Live CDs/USBs, Ubuntu seems to have an 80% success rate. I managed to get SuSe installed during a window of the system actually booting but since then it has been pretty much unbootable. Error messages are very haphazard and change a lot. I have managed to find a set of boot parameters that (so far) has given me a stable boot however, as you will see from the parameters they also mean the system is running on 1 cpu with 1 core, rather than the available 1/8 configuration

The boot parameters that work are the defaults (specifying the root and such) with the following added: acpi=off noapic nolapic irqfixup irqpoll This gives me a stable boot and environment. Using that I have installed all the latest updates available.

If I remove the ACPI option I get a wall of Unexpected IRQ traps on vector 07. Assuming this means IRQ 7 it seems to be the intel HD Audio card. I have blacklisted the module under modprobe and confirmed that IRQ 7 now shows no loaded device/module however it still has (at the time of writing) 1089 interrups and also shows 1089 "ERR" which I can only assume means every single one of the IRQ interrupts is an error (which is basically what the startup screen says too).

I would comfortably use the system with ACPI off, at least for testing to see what effects it has on daily use but gimping the system from 8 cores to 1 is not good. I have tried setting the ACPI mode to HT in grub but the boot just hangs and crashes either completely unresponsive (even capslock doesn't work) or it hangs so long that I force it off with the power button.

The way I see it either the system can't handle the multi-core nature of the AMD A10 for whatever reason, using ACPI forces it to behave as a single core and so the system works or some other aspect of ACPI is causing the issues.

In terms of errors I often see Kernel tried to execute NX-protected page - exploit attempt errors and lots of Unexpected IRQ Trap on Vector 07 occasionally an error to the effect of disk by uid xxx was not found where this is the root disk but with the extra kernel options I get a stable and reliable boot.

I'm not sure where to head next really. I need to identify if it is ACPI in which case what particular device/module or if it's something else.

Links to useful images of command output: (wat? No imgur links allowed? Well that's unconventional. Imgur album of pics showing lscpu, boot options and /proc/interrupts can be found at (imgur dot com) /a/I0eo6
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 22nd July 2018 - 01:32 PM