Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Help, var, etc out of space on Ubuntu Server with plenty of space, Can't upgrade any packages, var and etc out of space
post Feb 27 2016, 11:59 AM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 6
Joined: 27-February 16
Member No.: 19,053

Hi, I have an Ubuntu server 14.04 set up on an old laptop. It has been working well for a year or two.

It is configured to boot off of a flash drive. I have two external USB hard drives set up for SMB shares. It does not use the internal hard drive on the laptop. I set it up originally by following a guide, but don't remember the details of how it works.

I recently tried to update some services through Webmin (as I had been doing periodically) and was not able to. The message was:

Failed to fetch package list : Failed to open /etc/webmin/package-updates/current.cache for writing : No space left on device

The flash drive and the USB hard drives have plenty of space. I have tried restarting the machine and clearing tmpfs and it does not help.

I would appreciate any help.

df -h reports:
Filesystem Size Used Avail Use% Mounted on
/dev/sda1 14G 11G 2.2G 84% /
none 4.0K 0 4.0K 0% /sys/fs/cgroup
udev 487M 4.0K 487M 1% /dev
tmpfs 100M 3.0M 97M 3% /run
none 5.0M 0 5.0M 0% /run/lock
none 497M 0 497M 0% /run/shm
none 100M 0 100M 0% /run/user
/dev/sdc1 2.8T 2.0T 811G 71% /mnt/Seagate3TB
/dev/sdb1 1.9T 1.6T 309G 84% /mnt/External2TB

Operating system: Ubuntu Linux 14.04
Webmin version: 1.690
Kernel and CPU Linux 3.13.0-65-generic on i686
Processor information Genuine Intel® CPU U1400 @ 1.20GHz, 1 cores
System uptime 26 days, 20 hours, 38 minutes
Running processes 88
CPU load averages 0.00 (1 min) 0.01 (5 mins) 0.05 (15 mins)
CPU usage 3% user, 0% kernel, 0% IO, 97% idle
Real memory 312.14 MB used, 992.35 MB total
Virtual memory 32.61 MB used, 1012 MB total
Local disk space 3.42 TB used, 4.56 TB total

Package updates 150 package updates are available

Update packages through webmin:
Failed to fetch package list : Failed to open /etc/webmin/package-updates/current.cache for writing : No space left on device

sudo dpkg --configure -a
dpkg: error: unable to create new file '/var/lib/dpkg/status-new': No space left on device
Go to the top of the page
+Quote Post
Start new topic
post Feb 27 2016, 01:21 PM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,807
Joined: 23-January 03
Member No.: 360

/dev/sda1 912128 912128 0 100% /

As expected you have run out of inodes. In a nutshell it is a data structure that contains the files metadata. inodes are created when the partition is formatted and the number can not be easily changed on a running system. At the moment the only way to fix your problem is to delete files in sda1. Old kernels is a start but without knowing how much other stuff you have I do not know what else to suggest. Take a look at the files in your home directories.
Go to the top of the page
+Quote Post

Posts in this topic

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 23rd July 2018 - 07:03 AM