Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
> Samba and Windows 10
post Dec 10 2015, 02:42 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 10-December 15
Member No.: 19,012

Hi All,

I am both new to Linux and to these forums so please excuse any silly questions that I might ask.

I tried posting this on the Centos forums but got no reply, so I am going to try here. I have a Centos 7 system in my home that I want to use as a local web server just for development and testing purposes, not to actually host web files. I will only access it from computers within the network. For that reason I would like to share the /var/www/html folder with my Windows machines. I have installed Samba and configured it to the best that I know how. Here is my smb.conf file:


netbios name = MYSERVER
workgroup = WORKGROUP
security = user
encrypt passwords = yes
wins support = yes
name resolve order = wins lmhosts host bcast
smb passwd file = /etc/samba/smbpasswd
interfaces =
unix charset = UTF-8
dos charset = CP932
hosts allow =
map to guest = Bad User
max protocol = smb2
log file = %s.log
log level = 3

comment = shared web hosting directory
path = /var/www/html
writeable = yes
browsable = yes
create mask = 0770
force group = Share
public = yes
force create mode = 0770
valid users = Share DaveB
locking = yes

Here are the permissions for the html file:
[root@daveb-workgroup html]# ls -alv
total 4
drwxr-xr-x. 2 Share Share 17 Dec  7 12:14 .
drwxr-xr-x. 4 Share Share 31 Dec  7 09:10 ..

I tried to post part of the smb error log here, but my post was to long. I will post it in a reply.

When I try to access Share-html from Windows 10, I can access the computer by its IP address and see the share. I can also login using my credentials, but I get a permissions error if I try to open the shared folder. Windows tells me "You do not have permission to access\Share_html". I have been searching Google for the better part of 2 days. One person said they fixed it byt changing how their Workgroup was configured in Windows, but that is as close to an answer as I can find and it really doesn't help me much.

Can anyone here offer any insight?

Go to the top of the page
+Quote Post
Start new topic
Replies (1 - 1)
post Dec 11 2015, 10:47 AM
Post #2

Its GNU/

Group: Support Specialist
Posts: 1,807
Joined: 23-January 03
Member No.: 360

This might help.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th July 2018 - 05:28 AM