Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )

Advanced DNS Management
New ZoneEdit. New Managment.


Sign Up Now
Reply to this topicStart new topic
> Deepin Boot Woes
post Aug 27 2014, 02:17 PM
Post #1

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 27-August 14
Member No.: 18,780


I'm still very new to linux so forgive my confusion with a lot of this stuff, its very new to me. Also sorry about the wall of text in advance. I'm trying to install Deepin onto a flash drive that I can carry around with me and use on random computers (friends and school). I have a 64 gb Sandisk Ultra. It uses USB 3.0 and the speeds are plenty fast to run linux off of. I originally wanted to have 1/2 of it be for linux, 1/2 for NTFS storage. I formatted the flash drive and installed Deepin from a different installation USB. I'm able to boot up, mash F12 and get on Deepin fine the first time. The problem is that as soon as I remove the flash drive and switch over to windows, I lose the boot option for Deepin next time I try to use it. Normally there is an option to boot to "linuxdeepin2014" or something similar to that. But it disappears after I remove the flash drive and re-insert it. It can still see the flash drive and gives me to option to boot from it, but that launches me straight into windows instead of Deepin. I've tried removing the storage partition and just installing Deepin on one partition. Same problem, I can get on once after the install and then once I remove it the boot option disappears. If I use my installation USB to view the flash drive everything is still there and it still has the linux distro on it, I just can't boot to it for some reason.

Any help would be greatly appreciated. I've been trying for about a week off and on to get it working. Just about at my wits end.

Thanks in advance!
Go to the top of the page
+Quote Post
post Sep 9 2014, 02:13 PM
Post #2

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 9-September 14
Member No.: 18,785

Hi friendly linux people.

I'm having a very similar problem. I'm relatively new to linux (have been a Apple/Mac user for the past 25 years) and have tried installing several different distros (Mint 17, Mageia 4, Ubuntu 14.04.1, Manjaro 0.8.10; tried all first using a live USB), including the current version of Deepin. Prior to Deepin, all previous installations were successful. I have some very basic programming knowledge and a basic handle of the CL. I had a dual boot setup with Mageia and Manjaro, but didn't hugely care for Mageia and wanted to dual boot Manjaro and Deepin. After installing Deepin, I cannot get either of them to boot from the hard drive. I can successfully boot from my USB that has the Deepin live ISO on it, but nothing will boot from the HD. Additionally, when I try to boot from one of my other USB's, with a different distro, it tells me "No Operating System Found". All USB flash drives have been tested on another computer and they all work fine. I even attempted DBAN to create a fresh install, but got the same error as above. I have also attemted to re-install Deepin several times, including reformatting the HD and creating new partitions during the process. After it tells me I've a successful install, I attempt to reboot and get nothing (okay, it's a blank screen with a cursor that won't move). I cannot seem to find that this is a known issue with Deepin either. I'm installing a new 250G SSD (the current HD will be used as an external) this week and want to get this resolved before I do, so I know that whatever I install will work. Any help is much appreciated.

For reference:
Dell 13z (5323)
i5 - 1.7ghz
500G HD
8G ram

Thanks again.
Go to the top of the page
+Quote Post
post Jan 17 2015, 06:54 AM
Post #3

Whats this Lie-nix Thing?

Group: Members
Posts: 1
Joined: 17-January 15
Member No.: 18,823

Hey people,
Having same issue here.
I have a laptop with UEFI and Legacy boot firmware.
The setting was on Legacy since a long time and I never had any issues with any linux or windows installations.

Today I thought I would try Deepin, written the 64bit ISO to USB drive using USB Image Writer under Linux Mint 17.
Then proceeded to boot from it, no issues, Deepin installer loaded fine, proceeded to install, the partitioner was set to Simple mode.
It installed and said 'Remove media and reboot' so I removed USB drive, clicked ok, it rebooted and went into PXE boot (tried to boot from Network),
because it couldn't find any other bootable devices. PXE boot is the last on the boot order, I checked. And when PXE and all other options were disabled
except for the hard drive, it comes up with "No Boot Device or Operating System found, Please install an Operating System"

Then I had a thought, even though that's ridiculous,
but what if they designed it to only install and boot using UEFI if such firmware was detected? So since I could still boot from USB drive ok, I proceeded to
modify the UEFI settings, enabling UEFI Boot (Switching from Legacy mode) settings all options to correct settings, disabled secure boot etc. and went on to
install it. This time I selected Expert mode and it conveniently didn't let me do anything to the drive once I selected UEFI Bootloader, and kept saying the drive needs
to be GPT partitioned to support it. So after some googling around I found someone saying that Expert mode does NOT support GPT partitioning and you have to go
with default Simple mode for it to work. Alas I tried the simple mode and still no luck, now UEFI loads fine, then says no bootable system was found and your
computer will now shutdown.

Now I really really really hope this stupid clucking things didn't stuff up my drive to the point of me now having to spend hours repairing it because of some dev hindsight.
I am about to try installing another distro and crossing fingers that boots, if not will report back and hopefully not break the keyboard thanks to someone's idiocy.

How they could get such a basic thing, so wrong eludes me. By that I mean- the most required to have anything working at all, that every other distro gets right these days.
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:


RSS Lo-Fi Version Time is now: 18th July 2018 - 03:50 AM