Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> My cronjob with wget, url seems to be chopping because of $ sign
oracle765
post Jan 8 2014, 08:17 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 8-January 14
Member No.: 18,617



Hi All

I have a CRONJOB like so which basically tries to download a csv from a website who provide me with the full url

* * * * * /home/oracle765/public_html/scripts/feedimport.sh


Which runs this .SHFILE

/usr/bin/wget -O "/home/oracle765/public_html/feed/crazysales.csv" "http://dashboard.commissionfactory.com.au/Affiliate/Creatives/DataFeeds/jPvRtY22g7Od7pizj7SX5Mai1O$Aspa1hOXb8Yzlm7at4KOk4uyktvrtreLs8qHktLey$bT$9fCjt7m2uvn79YfvluHFssOl2vfSlK6Dfg==/";


Problem is it comes across the $ sign(i think) and cuts part of the url away so i only get a blank CSV file the url above ends up like this one below, I have had a look and it looks
like something to do with the 2 dollar signs not showing the url characters between in between them

---http://dashboard.commissionfactory.com.au/Affiliate/Creatives/DataFeeds/jPvRtY22g7Od7pizj7SX5Mai1OfCjt7m2uvn79YfvluHFssOl2vfSlK6Dfg==/

Hope this make sense
I have put the --- before the http so it does not post as a link
any ideas

thanks in advance
Go to the top of the page
 
+Quote Post

Posts in this topic
- oracle765   My cronjob with wget   Jan 8 2014, 08:17 AM


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 10:05 AM