Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> ls-la unknown color scheme in terminal mode, problems with Ubuntu 12.04 and ls-la results
eightbits
post Oct 19 2013, 08:34 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 3
Joined: 19-October 13
Member No.: 18,562



Hello, new user here. I recently downloaded and unziped a file that contains examples of python files. Once unziped, in terminal mode the listing of
that directory shows the directories in that directory as a green background and blue foreground. I do not find a reference to that color scheme,
I am using Ubuntu 12.04.
The directories are named such as: Chapter-01 up to Chapter-18 .

The problem: I can not execute the example name.py files using ".\filename.py" as I can do with other py files (using the terminal mode).
I also get an error message that this is not a dirctory.
I CAN execute the file by using "python filename.py"
Other files not in this directory execute as been in the past.
Also, I can not execute the file(s) using the Desktop file menu. I have insured that the py files have execute permission as well.

The pythonfiles/ scripts run as expected using IDLE the python IDE.

This has me stumped and probally a simple way to understand, except for me :-).

I am thinking this has something to do with the way the zipped file was extracted but don't have a clue. I used the archive tool that is executed when I click on the
file.

I am hoping that I can get some insight so I can continue on in learning to use GUI Python code.

Thanks for any help.

PS: I do have a screen capture if required and I know how to post it.
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
michaelk
post Oct 20 2013, 11:26 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



Difficult to say what the problem is but here are some things to check.
Make sure you are using the correct shebang in the first line of your program.
Make sure the permissions are set for executable
Make sure you are using the correct syntax to run the program i.e ./filename.py
If there are spaces in the file name make sure you escape the space or use quotes.
The example program might have errors and or expect different directories.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 24th October 2017 - 06:34 AM