Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> Can't install this software - "Undefined variable"
robin
post Apr 14 2013, 12:01 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 14-April 13
Member No.: 18,210



Hello

I've been trying to install this software called Aperture Photometry Tool, even though I follow their instructions I can't get it working. I tried to contact them but I haven't gotten a reply yet (after 3 weeks of waiting). I therefore wonder if you might be able to help me out. The instructions to the installations I've been following can be found below:

-------------------------------------------------------------------------------------
Installation instructions (and uninstalling previous version of APT):

cp APT_platform_independent_v2.3.2.tar.gz ~/Applications
cd ~/Applications
rm -rf APT_v2.3.1 (if you installed it here last time)
gunzip APT_platform_independent_v2.3.2.tar.gz
tar xvf APT_platform_independent_v2.3.2.tar
rm APT_platform_independent_v2.3.2.tar

Now, you need to set up your environment. If your default shell is bash, add these lines to your .bash_profile file (or change from 2.3.1 to 2.3.2 if you installed the previous version of APT):

export APT_HOME=/Applications/APT_v2.3.2
export PATH=$APT_HOME:$PATH
export APT_ARCH=MAC (omit if a Mac is not the target machine)
-------------------------------------------------------------------------------------

When I later try to run ./APT.csh while in the directory /home/robin/Applications/APT_v2.3.3. I get
"APT_ARCH: Undefined variable."
Why is that? When I go to my .bash_profile file I have added the two lines (see above). I've been told that I edit the .bash_profile file in "/home/robin" with the command sudo gedit .bash_profile. Is this correct? Thanks in advance.

Note that the version I've been installing is APT_v2.3.3 and not APT_v2.3.2 as the instructions above are from. But this is easily modified of course in the export lines.

//Robin
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies
robin
post May 1 2013, 10:48 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 8
Joined: 14-April 13
Member No.: 18,210



Ahh I see thanks. Still can't get this software working... Still thanks for all your help.
Go to the top of the page
 
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 22nd October 2017 - 10:39 AM