Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Samba for multi-subnet does not work
NiceLittleRabbit
post Dec 31 2012, 07:49 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 29-July 11
Member No.: 15,486



Hello,

I have a multi-subnet at home (10.26.33.0/24 and 10.26.34.0/24) and have set up a Samba server on 10.26.2.14.

Everyone can ping everyone on these networks.

However, the Samba server is not accessible from any computer, and Windows network autodiscover funcionality, which used to see the Samba shares, does not see anything.

Let me quote the results of testparm:

CODE
Load smb config files from /etc/samba/smb.conf
rlimit_max: rlimit_max (1024) below minimum Windows limit (16384)
Processing section "[homes]"
Loaded services file OK.
Server role: ROLE_STANDALONE
Press enter to see a dump of your service definitions

[global]
        workgroup = WORKGROUP
        server string = Samba %v on %h
        interfaces = eth0
        map to guest = Bad User
        null passwords = Yes
        obey pam restrictions = Yes
        passwd program = /usr/bin/passwd %u
        passwd chat = *Enter\snew\sLinux\spassword:*%n\n*Retype\snew\sLinux\spassword:*%n\n*Password\updated\ssuccessfully*.
        smb ports = 139
        add user script = /usr/sbin/useradd -m %u
        delete user script = /usr/sbin/userdel -r %u
        add group script = /usr/sbin/groupadd %g
        delete group script = /usr/sbin/groupdel %g
        add user to group script = /usr/sbin/groupmod -A %u %g
        delete user from group script = /usr/sbin/groupmod -R %u %g
        add machine script = /usr/sbin/adduser -s /bin/false -d /var/lib/nobody %u
        os level = 65
        preferred master = Yes
        wins proxy = Yes
        wins support = Yes
        hosts allow = 10.26.33.0/255.255.255.0, 10.26.34.0/255.255.255.0, 127.0.0.1, ::1
        hosts deny = ALL

[homes]
        comment = Home Directories
        valid users = %S
        read only = No
        create mask = 03700
        directory mask = 03700
        browseable = No


And then, /etc/samba/smb.conf:

CODE
[global]
workgroup = WORKGROUP
netbios name = home
;smb ports = 139
;printcap name = cups
;printing = cups
;load printers = yes
;disable spoolss = yes
;show add printer wizard = No
server string = Samba %v on %h
map to guest = Bad User

security = user
null passwords = yes
encrypt passwords = true
passdb backend = tdbsam
obey pam restrictions = Yes
passwd program = /usr/bin/passwd %u
passwd chat = *Enter\snew\sLinux\spassword:*%n\n*Retype\snew\sLinux\spassword:*%n\n*Password\updated\ssuccessfully*.
add user script = /usr/sbin/useradd -m %u
delete user script = /usr/sbin/userdel -r %u
add group script = /usr/sbin/groupadd %g
delete group script = /usr/sbin/groupdel %g
add user to group script = /usr/sbin/groupmod -A %u %g
delete user from group script = /usr/sbin/groupmod -R %u %g
add machine script = /usr/sbin/adduser -s /bin/false -d /var/lib/nobody %u

preferred master = Yes
domain master = Yes
wins support = Yes
wins proxy = Yes
os level = 65
dns proxy = Yes
interfaces = eth0
hosts deny = ALL
hosts allow = 10.26.33. 10.26.34. 127.0.0.1 ::1

[homes]
comment = Home Directories
admin users = boris
valid users = %S
hide dot files = yes
read only = No
browseable = No
create mask = 3700
directory mask = 3700


Finally, the result of smbclient -L localhost:

CODE
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.6]

        Sharename       Type      Comment
        ---------       ----      -------
        IPC$            IPC       IPC Service (Samba 3.5.6 on home)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.5.6]

        Server               Comment
        ---------            -------
        HOME                 Samba 3.5.6 on home

        Workgroup            Master
        ---------            -------
        WORKGROUP          HOME


So, the sad truth is that this set up does not work. It used to work on a single subnet and with WEP, but we moved to WPA2 and multiple subnets.

Any help will be very much appreciated, and obviously I will give any requested complementary information required to solve the issue at hand.

Thank you in advance
Go to the top of the page
 
+Quote Post
michaelk
post Jan 1 2013, 09:05 AM
Post #2


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,800
Joined: 23-January 03
Member No.: 360



Have you tried setting up multiple interfaces i.e.

interfaces = eth0 10.26.33.0/24 10.26.34.0/24
Go to the top of the page
 
+Quote Post
NiceLittleRabbit
post Jan 6 2013, 04:46 PM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 29-July 11
Member No.: 15,486



QUOTE (michaelk @ Jan 1 2013, 03:05 PM) *
Have you tried setting up multiple interfaces i.e.

interfaces = eth0 10.26.33.0/24 10.26.34.0/24


Hello,

Yes, I tried that after reading your post, but that does not seem to have much effect. Thank you for this idea.

Any other idea?

Regards
Go to the top of the page
 
+Quote Post
NiceLittleRabbit
post Jan 7 2013, 05:51 PM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 6
Joined: 29-July 11
Member No.: 15,486



Well, actually that worked after all. It just needed some time to settle down.

Thank you for your help!!

Regards
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 16th December 2017 - 09:06 PM