Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Mounting, mounting with fstab
miken
post Jun 14 2003, 04:29 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 14-June 03
Member No.: 961



Hi to all.

I have trouble mounting a fat32 partition onto RH 8.0 with /etc/fstab.

I placed this line in /etc/fstab:
/dev/hdb5 /mnt/windows vfat umask 0 0

On reboot, I got this error when the partitions were being mounted:

"wrong fs type, bad option, bad superblock on /dev/hdb5,
or too many mounted file systems"


When I do this:
[root@faith8 mnt]# ls
cdrom cdrom1 floppy windows
[root@faith8 mnt]# mount -t vfat /dev/hdb5 windows

The partition is mounted and I can access it just fine. Any clue??
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 14 2003, 05:05 AM
Post #2


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



Hiya, Could you do a favour and copy the whole of your fstab file up here? I could hasard a guess but without seeing what it is that you've got in the complete file I can't really help.

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
miken
post Jun 14 2003, 10:30 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 2
Joined: 14-June 03
Member No.: 961



Thanks for your offer.

After reading up on 'umask' on forums and how tos, I thought it was the correct option but after many hrs, I reluctantly tried using the 'defaults' option. This worked but I don't know why.

Changed:
/dev/hdb5 /mnt/windows vfat umask 0 0

to:
/dev/hdb5 /mnt/windows vfat defaults 0 0
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 14 2003, 10:42 AM
Post #4


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



Oh thats great. I'm glad that you've put the solution up here. Sorry i couldn't put any solution straight away.

I'm also having problems with my fstab file, in the fact that the absence on any data in the file and the inability to write over it i'm a little stuck.

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
michaelk
post Jun 14 2003, 04:14 PM
Post #5


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,800
Joined: 23-January 03
Member No.: 360



To allow users to read / write to the vfat partition.

/dev/hd5 /mnt/windows vfat user,umask=000 0 0

jay-jay:
Need to be logged in as root to write to anything in the /etc directory.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 13th December 2017 - 01:51 PM