Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
> Lftp - access failed, LFTP error
jaythorpe
post Jun 29 2012, 06:55 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 29-June 12
Member No.: 17,684



I wanted to setup LFTP so that I can transfer my files/folders to my webhost
I used this guide exactly as it stated

When crontab runs the script I get this error

mirror: Access failed: 550 Can't change directory to /home/gmod/orangebox/garrysmod: No such file or directory

Code I used

open ftp://******:*******@146.255.37.1
mirror -v --only-newer /home/gmod/orangebox/garrysmod/ /146.255.37.1/public_html/garrysmod/

The directory does exist and permission for directories are set to 0777
Any idea's how to fix this (Try and explain this simply only used linux for a few week)
Go to the top of the page
 
+Quote Post
 
Start new topic
Replies (1 - 1)
Kev
post Jul 19 2012, 03:45 PM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 19-July 12
Member No.: 17,734



Hi Jaythorpe

I presume you didn't resolve this issue. I have exactly the same problem though I cannot even mirror using lftp at the command line. I used:

lftp
open [bookmarked site]
mirror -i "\.(html|css)$" /home/kevinm/lftptest/ /

Response:
mirror: Access failed: 550 /home/kevinm/lftptest: No such file or directory
1 error detected

lftp connects successfully at the open command but fails with the error shown. The directory does exist, is owned by me and has permissions of 777. The transfer log is always 0 bytes long and I get exactly the same error if I run the command as root.

If I just try to get or put a file using lftp it works fine (with the correct entries in the transfer log) so it's just mirror that doesn't work.

I am running Xubuntu 10.04LTS and lftp is at version 4.0.2 the debian bug site with bug ID=675604 suggests it's buggy right up to the latest version - 4.3.8. I can't even install this because it fails the dependencies. I've wasted ages trying to find a solution but if there is one - I can't find it!

I'm having to backup my site manually, as I simply cannot get lftp mirror to work with Xubuntu Lucid.

Maybe this will help someone out there.
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 21st October 2017 - 11:01 AM