Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Problems Installing Mandrake 9.1, won't bring up KDE / won't install Grub
sjzabel
post Jun 9 2003, 08:23 PM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 11
Joined: 22-May 03
Member No.: 875



Hi,
After having many mouse/display problems with SuSE 8.1 I switched to Mandrake 9.1.

I thought that I had the easiest install of my life... but I was wrong.
I have a couple of problems :
#1 I was booting up using LiLO with the SuSE, however, I selected Grub at the end of the Mandrake installation. When I reboot it still brings up LiLO.

#2 KDE won't start; even though I select it to start when I reboot.

#3 I see all sorts of error in the load screen... I wasn't able to pick them all up, but I see that it isn't able to load all (or part of) my USB drivers. When it gets done booting, I get the command line version; however, it no longer finds my USB keyboard. I have to put in a serial keyboard which it picks just fine. The weird thing is that I had no problems using my keyboard during the installation.

Ok... I'm a newbie. If I was installing a copy of Windows I would have reformat the partition before I installed a new OS... but in Linux I don't know how.

I'm wondering if my problems are stemming from the fact that I just wrote the Mandrake right on top of the SuSE.

Any thoughts... I'm going crazy over here.
thanks,
Stephen


--------------------
Thanks,
Stephen

Athalon XP 2200
Dual Boot Grub (hopefully)
1. Mandrake 9.1 (hopefully)
2. Windoze XP Home
Go to the top of the page
 
+Quote Post
sjzabel
post Jun 10 2003, 09:37 AM
Post #2


Whats this Lie-nix Thing?
*

Group: Members
Posts: 11
Joined: 22-May 03
Member No.: 875



Ok, Nobody has any ideas... could someone at least point me towards documentation on how to wipe a Linux partition before installing onto it.

Or some documenation on how to unistall LiLO.

Thanks,
Stephen


--------------------
Thanks,
Stephen

Athalon XP 2200
Dual Boot Grub (hopefully)
1. Mandrake 9.1 (hopefully)
2. Windoze XP Home
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 10 2003, 10:03 AM
Post #3


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



Hiya Stephen.

Sorry, I can't help, but just to let you know that this is a candian site and so the people that run and help are candian . . . that puts their time at about 10 am . . . So, they won't be up yet. I'm in England and it's 4pm so i'm up and about.

I'm just finding out for myself how to reformat a partition for myself. So, if you can hold on, i'll post it up here.

As for Lilo, I'm not all that sure how you set it up, but if your in a rush and know your way round linux stuff (I don't) then try google. I just tried it but it churns up alot and it's specific, so I would define my search more than just "Installing Lilo".

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
sjzabel
post Jun 10 2003, 10:14 AM
Post #4


Whats this Lie-nix Thing?
*

Group: Members
Posts: 11
Joined: 22-May 03
Member No.: 875



Thanks Jay-Jay.

If you find out how to reformat a partition, let me know. I'm sitting at work right now... so, I will have to wait untill later to look anything up.

Thanks,
Stephen


--------------------
Thanks,
Stephen

Athalon XP 2200
Dual Boot Grub (hopefully)
1. Mandrake 9.1 (hopefully)
2. Windoze XP Home
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 10 2003, 10:40 AM
Post #5


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



Well. I just managed to properly ruined my linux machine just rite now . . . but then it wasn't exactly working before I reformatted a partition . . . .

I'm going to laydown someplace quite and cry, after 200+ hours of trying to X working on it . . . and now this . . . but I'm not giving up! It's become a full time job just trying to get it to work . . . but i'm not giving up!

I let you know once I worked out, but I wouldn't hold out too long for me . . .

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
sjzabel
post Jun 10 2003, 11:03 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 11
Joined: 22-May 03
Member No.: 875



Did you reformatt the wrong partition?


--------------------
Thanks,
Stephen

Athalon XP 2200
Dual Boot Grub (hopefully)
1. Mandrake 9.1 (hopefully)
2. Windoze XP Home
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 10 2003, 12:52 PM
Post #7


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



No nothing like that, just managed to loose my fstab (partion detail file)

Havin' a WORLD of fun!

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
michaelk
post Jun 10 2003, 09:31 PM
Post #8


Its GNU/Linuxhelp.net
*******

Group: Support Specialist
Posts: 1,797
Joined: 23-January 03
Member No.: 360



I don't run SUSE but I would expect there to be an option when you setup up the partitions to reformat it.

It might be that since SUSE is abit different than Mandrake that not reformating could mess things up.

Check SUSE documentation for partition and formating a drive during the install process.
Go to the top of the page
 
+Quote Post
snowdog
post Jun 12 2003, 04:31 PM
Post #9


Whats this Lie-nix Thing?
*

Group: Members
Posts: 1
Joined: 12-June 03
From: Ontario, Canada
Member No.: 954



When you installed Mandrake, did you install GRUB to the MBR? With either GRUB or LILO, you have to install them to the MBR. They will read whatever else is there (if there is anything) and then add it to itself.

Formatting hard drives is no prob. During the install, Mandrake will show you a nice graphical partitioning tool. Choose the empty space you want for Mandrake, carve it up as you would like, click next (or accept), then choose the partitions to format. If you are dual-booting DO NOT format the Windows partition (hda1 -- I think).

To wipe the drive completely before beginning, easiest way would be to use a Windows boot disk. At the DOS prompt, enter fdisk /mbr. This will clear the MBR. Then run fdisk and blow out any partitions you don't want. You don't need to format with the Windows disk. If fdisk complains about a partition, use "delpart" http://www.russelltexas.com/delpart.htm This is an old WinNT3.51 tool. It'll blow away any partition. I've used it a lot over the last couple years. You can make a Linux boot disk and use the Linux fdisk tool, it has more balls than the Windows one, but requires a little more reading.

What happens when you try to start KDE? What errors are you getting? If you reinstall, do not let Mandrake start X at boot. Best to boot to the command line in case there are any problems. Once everything is going good, you can set it to boot to KDE or whatever you want. To start X from the command line, type "startx" (no quotes).

The USB thing, I'm not to sure about. What motherboard are you using? Maybe a reinstall would fix that.

Hope any of this helps.

snowdog
Go to the top of the page
 
+Quote Post
sjzabel
post Jun 19 2003, 01:50 AM
Post #10


Whats this Lie-nix Thing?
*

Group: Members
Posts: 11
Joined: 22-May 03
Member No.: 875



Thank you all,
I went in and deleted my Linux partition, deleted the MBR and reinstalled.

: ) everything went off with out a hitch... now to learn me some Linux

Thanks,
Stephen


--------------------
Thanks,
Stephen

Athalon XP 2200
Dual Boot Grub (hopefully)
1. Mandrake 9.1 (hopefully)
2. Windoze XP Home
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 20th October 2017 - 08:30 PM