Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
 
Reply to this topicStart new topic
> Isa Network Card, Help to install the eepro module
giblet
post Jun 8 2003, 07:51 AM
Post #1


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 8-June 03
Member No.: 941



Hi,

I am currently trying to set up an old machine as an internet gateway / firewall. The machine (IBM P90, 96MB RAM, 2x4GB HDD) only has 2 PCI slots so I am forced to use one ISA network card (the other slots contain a PCI network card, not yet installed (pending the installation of the ISA card), and an AHA2940UW SCSI card). I have installed Red Hat 8 - without X.

I have an Intel EtherExpress Pro 10+ card. My research has led me to believe that the eepro module is the one for me, but I have no clue how to get my machine to use it. The locate command shows me that it is on my disk.

NB I am a relatively new user of linux (12 months), my experience is limited to Red Hat 7 and 8 on 500MHz + machines with PCI and PnP and running X with Gnome.

Any help here would be great, even if it is just a pointer to a more in depth book than the SAMS published Red Hat unleashed series.

Thanks.
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 8 2003, 08:48 AM
Post #2


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



my best guess, i'm new to linux myself (newer than you by about 11months)

try

"lsmod", this will list you loaded modules, see is you device is there most likely it won't be then try

"modprobe -t drivers/net *" this will load all network driver modules, or try them until it finds the rightone

and then try

"lsmod" again and see if it's there, it should be.

Let me know if that works then we can find a way of keeping it loaded, which it might do automatically.

If you wanna know about books the important thread on books for newbie's is well worth the read. Also, don't forget to check out "who was your first?" page, dedicated to first time dealings with Linux.

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
giblet
post Jun 8 2003, 09:42 AM
Post #3


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 8-June 03
Member No.: 941



OK, I have entered: "options eepro io=0x210" into /etc/conf.modules (I checked the address of my card and it is 210), rebooted, and then issued modprobe eepro. Subsequently lsmod shows the eepro there, but it doesn't automatically come up at reboot. Also I don't know how to get it assigned to be eth0.
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 8 2003, 10:47 AM
Post #4


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



does it work for the moment, even though it doesn't load on start up? I mean, i don't really know what to do . . . so if it works for the moment we can wait till someone who knows more comes online, but if it doesn't work i'm happy to keep helping you try.

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 8 2003, 10:57 AM
Post #5


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



Sorry, this post was wrong . . . just booted up my linux machine to see info was incorrect.

Sorry

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post
giblet
post Jun 11 2003, 03:32 AM
Post #6


Whats this Lie-nix Thing?
*

Group: Members
Posts: 23
Joined: 8-June 03
Member No.: 941



I worked it out, I added these lines to /etc/modueles.conf

alias eth1 eepro
options eepro io=0x210

and then created /etc/sysconfig/network-scripts/ifcfg-eth1

DEVICE=eth1
IPADDR=0.0.0.0
NETMASK=255.0.0.0
ONBOOT=yes
BOOTPROTO=none

(the IP address is blank because I am using the card for a PPPOE connection)

Thanks for your help anyway, Jay Jay.
Go to the top of the page
 
+Quote Post
Jay-Jay
post Jun 11 2003, 05:04 AM
Post #7


I Eat C Code for Breakfast
****

Group: Members
Posts: 162
Joined: 2-June 03
From: London (UK)
Member No.: 914



No problem.

Thanks very much for posting up the solution. If they put a PAQ's page up we'll be able to keep things like this . . .

I'm campaigning for a PAQ's page wink.gif so, have a look at my post if you interested, it's probably on page 2 now.

Jay-Jay


--------------------
I have a new toothbrush that had rubber prongs to massage my gums while I brush. How odd! (Query of life)
Go to the top of the page
 
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



RSS Lo-Fi Version Time is now: 19th October 2017 - 03:59 AM