Linux Help
guides forums blogs
Home Desktops Distributions ISO Images Logos Newbies Reviews Software Support & Resources Linuxhelp Wiki

Welcome Guest ( Log In | Register )



Advanced DNS Management
New ZoneEdit. New Managment.

FREE DNS Is Back

Sign Up Now
2 Pages V   1 2 >

andrewjenkins
Posted on: Jan 3 2004, 02:28 AM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


The place to start with wireless support is www.linux-wlan.org. Their compatability list says:

Linksys 802.11b WMP11 PCI Prism2/2.5/3 Linux-wlan-ng Recent versions are Broadcom

This sounds like a similar situation to what I went through with my WPC11 - they are really two different cards, a Ver 3 and earlier, and a Ver 4. You have the version 4 - the broadcom.

Broadcom has linux support for two chipsets at http://www.broadcom.com/drivers/downloaddrivers.php. Are either of these yours? What relevant output does "cat /proc/pci" give you?

My WPC11 came with a sheet offering a free exchange for an earlier version. While I didn't go through with it (shipping would have cost more than the card itself), it may make more sense for you, if Linksys was nice enough to include it.
  Forum: Hardware Support · Post Preview: #7434 · Replies: 1 · Views: 3,337

andrewjenkins
Posted on: Jan 3 2004, 02:14 AM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


both version.h and autoconf.h are in kernel-dir/include/linux for all the kernels I've ever gotten. So, they should be at:

/usr/src/linux-kernel.2.4/include/version.h
/usr/src/linux-kernel.2.4/include/autoconf.h

It's very bizzare that they wouldn't be there. Did you download a kernel source? I don't use debian, but its possible they include by default a stub tree that contains basically only the Makefile and .config. I guess I would recommend downloading from www.kernel.org to get the vanilla sources, and also, make sure you have hard disk space when you unpack (df -h /usr/src), and that you have the proper permissions to unpack in /usr/src (probably means you have to be root).
  Forum: Hardware Support · Post Preview: #7433 · Replies: 1 · Views: 2,912

andrewjenkins
Posted on: Jan 3 2004, 02:02 AM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


The best way to do this is with a chroot jail. Chroot stands for "change root" and it actually changes the root directory under which an application is run. When users log in, a shell is automatically started for them, and their standard input and output are connected to it, usually /bin/bash in linux. For this, the root is "/" - the true root directory. But, a command like

chroot /home/jaileduser /bin/bash

will mean that first, chroot will make /home/jaileduser the root directory, and then execute /bin/bash in this root directory (what is really /home/jaileduser/bin/bash). The jaileduser will only be able to see things inside of /home/jaileduser - i.e. /mydocs/textfile.txt is actually /home/jaileduser/mydocs/textfile.txt. This is a security feature common with most ftp servers. When this happens, users can only execute the binaries you provide for them, and only touch the files in their directory. There's a good howto from the WU-FTPD installation guides:

http://www.wu-ftpd.org/HOWTO/guest.HOWTO

I'm assuming by SSL you mean SSH, in which case, you probably have to edit a little bit of /etc/ftponly to allow SSH connections as well. I have no idea what Ensim is, but chroot is typical for all FTP servers.
  Forum: Technical Support · Post Preview: #7432 · Replies: 1 · Views: 1,713

andrewjenkins
Posted on: Jan 3 2004, 01:33 AM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


If you are interested in actually running two operating systems simultaneously, then you are looking at something like VMWare. Wine is mainly for running one or two windows applications in linux, and its extra layers of emulation really slow it down. Wine isn't capable of emulating the entire Windows operating system. VMWare actually loads the Windows operating system inside of linux (I'm fuzzy on the details) and thus will give your Windows applications higher performance than Wine.
  Forum: Technical Support · Post Preview: #7431 · Replies: 4 · Views: 2,785

andrewjenkins
Posted on: Jun 6 2003, 04:19 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


Are you sure you have the right device file selected?
  Forum: Technical Support · Post Preview: #2763 · Replies: 1 · Views: 1,950

andrewjenkins
Posted on: Jun 6 2003, 02:54 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


I don't know if this is related, but for a while, Linux was unable to find memory past 64MB unless you told it to. This has been long sorted out, or so it was thought. When you type in "free" or "top" you'll get a memory summary. If you're stuck at the 64MB barrier, you'll have to pass some options to the kernel on start-up. In lilo, you have to get to the lilo boot: command line (I think you hit TAB if you get the menu). Type in the image name (probably "linux") followed by an append of a certain amount of memory:

boot: linux mem=511M

This will allow you to break through the 64MB barrier if this is indeed your problem.
  Forum: Technical Support · Post Preview: #2761 · Replies: 6 · Views: 3,923

andrewjenkins
Posted on: Jun 6 2003, 02:48 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


uname -r is telling you that you're currently running 2.4.18-586 (2.4.18, possibly your distro's modification #586?). We are intentionally upgrading to 2.4.20 - upgrading kernels within a minor branch (2.4) is o.k. - however, if you were currently in 2.2 or 2.3, the process would be different. I should have made sure, my mistake. But yes - 2.4.18 to 2.4.20 should be (relatively!) painless.
  Forum: Technical Support · Post Preview: #2760 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 11:54 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


I'd recommend:
http://www.kernel.org/pub/linux/kernel/v2....-2.4.20.tar.bz2
  Forum: Technical Support · Post Preview: #2753 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 11:21 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


Welcome to the Unix concept of mounting. Before you can read your CDROMs, floppies, windows c drive, you'll have to mount them. As you get more advanced, you can research fstab and automount, but for now, this will work:

mount device-name mountpoint -t filesystemtype

to mount a floppy, it'll be something like:

mount /dev/fd0 /mnt/floppy -t vfat

Assuming the floppy is a windows floppy disk.

to mount a CDROM, I'd recommend trying these methods in this order:

mount /mnt/cdrom
mount /dev/cdrom /mnt/cdrom -t iso9660
mount /dev/hdc /mnt/cdrom -t iso9660


Now, when you are finished with the disks, you have to unmount:

umount /dev/fd0
umount /dev/hdc

both mounting and unmounting probably have to be done as root.
  Forum: Technical Support · Post Preview: #2751 · Replies: 2 · Views: 2,351

andrewjenkins
Posted on: Jun 5 2003, 11:10 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


Does glxgears work (type glxgears at the terminal prompt)? If it does, GLX works. I don't know how glxinfo works, sorry.

For mplayer configure, maybe I'm not getting what you're saying. Are you typing:

./configure
make
make install

as root for all three (or at least the last one)?

And not getting any errors at all? The easiest way to check this is to do this
./configure &> configure_output
then do:
grep "***" configure_output
(The backslashes are necessary). Any lines that are output will contain three stars. These lines are errors - the making is failing because of them.

Similar for the rest:
make &> makelog
grep "***" makelog
make install &> makeinstalllog
grep "***" makeinstalllog

Another thing you might want to do is change configure to be:
./configure --prefix=/usr
then the files won't be installed in /usr/local, but instead in /usr. This would be, for logging, as
./configure --prefix=/usr &> configure_output
grep "***" configure_output

If all this works and you still cant find anything try:
updatedb
then:
locate mplayer

That'll output the locations of any files that have mplayer in their filename.
  Forum: Technical Support · Post Preview: #2750 · Replies: 2 · Views: 2,344

andrewjenkins
Posted on: Jun 5 2003, 10:21 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


You could try to get the kernel source package from your distro CDs, but this might not be 2.4.20. Either way, it's likely it'll have MTRRs as an option.

I'm thinking you're describing two computers, one with linux, and another with 98. It is possible to communicate between them. You could download the file on your 98 machine, then set it up to allow file and printer sharing, share the folder with the kernel in it, and then use the linux machine's SMBCLIENT to connect to the 98 machine and get the file. This is a difficult process, though.

I think there's an easier way. Your linux machine has a NIC, right, and you only have one IP. Obviously since you can't get X working you can't just open up netscape (or mozilla) and go get the file, but what you can do is use wget.

You're gonna have to set up the networking on your linux box.
First, get the info from your windows machine (run winipcfg) - it'll give you a DNS server, and then make sure your Win98 NIC is selected, it'll tell you 1) An IP for the NIC 2) A subnet mask 3) A default gateway. With these four (DNS, IP, subnet, default gateway) you can connect your linux box to the internet. As root type:

ipconfig eth0 NICIPNUMBER netmask SUBNETMASK
then:
route add default gw DEFAULTGATEWAYIP
then, add the dns to /etc/resolv.conf by adding the line:
nameserver DNSIP

Now, your linux box can use the internet. Try ping www.google.com - you should get a response. Terrific. Now to get the kernel file.

First try typing in "lynx" at the prompt - if it works, you'll get LYNX, the command line web browser. Press "g" (as in go) and you can type in an address to go to (www.kernel.org) then use the arrow keys to highlight the link you want and hit enter, keep doing this and then you'll eventually be highlighting linux-2.4.20.tar.bz2. Press "d" (as in download) to download the kernel.

OK, assuming lynx doesn't work and you can't or don't want to bother installing it. You have to get the exact URL for the kernel file and then type in:
wget http://www.kernel.org/pub/kernel/ (whatever the rest is)
and you'll download the kernel to the current directory. Now you've got it. You might want to copy it to /usr/src.

Most of this process will have to be done as root.
  Forum: Technical Support · Post Preview: #2748 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 08:27 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


It's not impossibly difficult, probably slightly easier than installing. And, it's something you probably will have to do sooner or later, it'd teach you a whole lot about the process.

The Linux Kernel HOWTO will give you great instructions on how, my previous post has a summary of what your steps are going to be. In the "Processor Type and Features" section of the config, you can enable MTRRs. I'm kind of surprised that your distro doesn't support MTRRs to begin with, and I'm still not sure this will fix the problem. It is something to try though.
  Forum: Technical Support · Post Preview: #2743 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 07:26 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


ok well you either don't have MTRRs or you don't have MTRR support enabled in the kernel.

Try:
dmesg | grep "mtrr"

This will tell you if the kernel has MTRR support. you could try to add in support if it isn't already there by

modprobe mtrr

as root.

If yo udon't get anything from dmesg, and modprobe doesn't work, then it's likely that you don't have MTRR support inthe kernel, so you'll have to recompile the kernel if you want to add MTRR support.
  Forum: Technical Support · Post Preview: #2741 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 07:14 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


I don't know. Debian says:
The i2c bus is used by many modern motherboards to provide hardware health monitoring data, like temperature and fan speed...
So I don't know why X cares about I2C. In your XF86Config file, in the section titled "Modules" is there a line concerning I2C or MTRRs? If there are, what happens when you add a "#" before them?

MTRRs shouldn't be necessary for X though - maybe accelerated X, but not like this. I can help you add them if that is the problem, I'm just not sure that it is. What happens when you do

cat /proc/mtrr

I get:
[root@x1-6-00-10-7a-69-e3-23 root]# cat /proc/mtrr
reg00: base=0x00000000 ( 0MB), size= 256MB: write-back, count=1
reg01: base=0x10000000 ( 256MB), size= 64MB: write-back, count=1
reg02: base=0xfd000000 (4048MB), size= 8MB: write-combining, count=2

Basically, if you get any output aside from an error, you have MTRRs enabled. It's possible your machine doesn't have MTRRs, even if they're supported in the kernel, your motherboard might just not have them. In this case, X should leave them alone, maybe it refuses?
  Forum: Technical Support · Post Preview: #2738 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 07:05 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


I can't offer any specific advice, but I do know RH has a history of not wanting people to use file managers as root. For most root tasks, RH (and a lot of the linux community) thinks you should only be using the console. Anything you're trying to do with the file manager can surely be done from the console.
  Forum: Technical Support · Post Preview: #2737 · Replies: 1 · Views: 2,112

andrewjenkins
Posted on: Jun 5 2003, 06:53 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


I have very little experience with internationalization (mostly trying to de-internationalize SuSE once). How to setup international keyboard in X Window with Xmodmap and XKB available at TLDP might help with internationalization. If you remove the uk variantness, does X start? Obviously, your keyboard won't work right this way, but then you'd know for sure that i18n is the problem.
  Forum: Technical Support · Post Preview: #2735 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 06:49 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


If you're interested in the spirit of the GNU Project and Linux, I recommend these two "bibles":

Free as in Freedom: Richard Stallman's Crusade for Freedom
Sam Williams
This is a biography of Richard Stallman, known on the net as RMS. He wrote, or assisted in writing many of the tools on any linux system, most notably GCC (the compiler that turns the linux kernel from source to something runnable), and GNU Emacs, the text editor. A good read for the philosophical justifications of free software.
This book is released in accordance with the GNU Free Documentation License, so it should be available on the internet somewhere, although I coughed up dinero for the hard-cover.

Just For Fun: The Story of An Accidental Revolutionary
Linus Torvalds and David Diamond
This is a (auto-)biography of Linus Torvalds, the guy behind the Linux kernel, and the front-page man for Linux. About every other chapter is written by Linus himself. This is a very lighthearted read. It's not GFDLed though - you have to buy it or find it in a library.
  Forum: Tips and Tricks · Post Preview: #2734 · Replies: 42 · Views: 106,980

andrewjenkins
Posted on: Jun 5 2003, 06:27 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


Unless it's foreign, it shouldn't be too strange. Here's some of my XF86Config (for X4), a Dell Latitude CPxJ laptop:

Section "ServerLayout"
Identifier "Anaconda Configured"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Mouse1" "SendCoreEvents"
InputDevice "Keyboard0" "CoreKeyboard"
EndSection

...

Section "InputDevice"
Identifier "Keyboard0"
Driver "keyboard"
...
# Option "XkbOptions" "ctrl:swapcaps"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
#Option "XkbVariant" ""
#Option "XkbOptions" ""
EndSection

...

Is it possible your mouse isn't set up right? This plagued me for a while - built-in laptop mice have bizarre protocols. This configuration allows me to use the touchpad (as Mouse1) and a hot-pluggable USB mouse (as Mouse0):
Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/input/mice"
Option "ZAxisMapping" "4 5"
#Option "Emulate3Buttons" "yes"
EndSection


Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Device" "/dev/psaux"
Option "Protocol" "NetMousePS/2"
Option "Emulate3Buttons" "no"
# Option "ZAxisMapping" "4 5"
EndSection

Good luck. It seems you're so close.
  Forum: Technical Support · Post Preview: #2732 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 05:23 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


Hmmm. Maybe gnome isn't starting correctly or something. Since you can't switch back to the console to get the errors, you can't see what the problem is. And, since X appears to be loading at least somewhat properly, the error probably isn't in the XFree86.0.log logfile.

If you want to record all the messages that appear on your console, try

startx &> ~/my_x_log

Then, all the output of X (and GNOME/KDE and all the subprograms) will be recorded in ~/my_x_log. If it hangs, wait about 30 seconds, then reboot, you should be able to open my_x_log and see the last thing it was doing before it hung. It might not be X that's hanging - X might be trying to start GNOME and GNOME is misconfigured, so it's hanging there. This happens to me when I don't have /etc/hosts set up properly, but your distro should have done that for you.

It'll probably help to increase X server verbosity. Try opening up /usr/X11R6/bin/startx, you should hopefully see the line:
defaultserverargs=""
Change this to:
defaultserverargs="-v"

This will make X tell you more of what its doing before it hangs. If you don't get interesting results, add another -v right after it, I think you can have up to 5 levels of verbosity, but at some point, you're just seeing crap that won't help at all.
  Forum: Technical Support · Post Preview: #2729 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 04:12 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


From kernel docs:
I2C (pronounce: I squared C) is a protocol developed by Philips. It is a
slow two-wire protocol (10-100 kHz), but it suffices for many types of
devices.

I don't think this is important to you (unless you have an I2C keyboard?), so we won't worry about that.

The accelerations one is probably closer - it mentions less than 8bpp. If you're using less than 8bpp, you are either initializing monochrome or 16 color (not 16 bit, buto nly 16 colors). Well, not you. X is deciding that you want less than 8bpp, probably because it can't get your video card to work, so its defaulting to some sort of VGA failsafe setting that's just gonna suck.

have you looked at the XFree86 Cirrus documentation?
X 3.3.6 supports more cards than the 4.0 series, perhaps yours is one of these unsupported cards? If so, you could try going back to X3.3.6 (you can still keep GNOME 2 or KDE or whatever the same). X4 has better support for DRI, AGP, GLX and graphics tablets and the like, but many many people still use X3.

Also, there's a page at berkeley of working Cirrus Logic XF86Configs here. But, these are all for X3.2 or X3.3. You can't just copy and paste because the config format changed between X3 and X4, but you can translate portions pretty easily, assuming that your card wasn't orphaned from X3 to X4.

If X won't support your cirrus card, you can try using it as a framebuffer device. This is how I got my KYRO II card to work. I could get full resolution (1024x768 on my monitor), do Mozilla, XMMS, all of that, but I couldn't ever play quake3. This might be suitable for you, but its a pain, it involves not only kernel compiling but also device modification and some more X tweaking.
  Forum: Technical Support · Post Preview: #2726 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 03:38 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


Probably not. The kernel would allow you to enable MTRRs if they aren't already, which they probably are. Kernel compiling is a good way to explore anyways, but obviously, this X problem is more urgent to you. Sorry I misled you down the kernel path. I'd stick to editing XF86Config until that works before changing the kernel. Try this:

grep "EE" /var/log/XFree86.0.log

This will print out all the error lines from the X logfile. Post them here and maybe somebody can help out.
  Forum: Technical Support · Post Preview: #2724 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 02:53 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


If you want to compile your very own kernel, you're gonna want to download a kernel source. There are about 3 or 4 kernel source branches, each maintained by different people, and different minor numbers as well. The official kernel source is kept at www.kernel.org. Alan Cox makes his own little variations, these are denoted with a "-ac".
For now, what you'll probably want to do is go to www.kernel.org, and dive into the public linux repository, then kernel, then the 2.4 series. 2.4 is the stable series, 2.5 is testing. Get the latest 2.4 (linux-2.4.20.tar.bz2 or linux-2.4.20.tar.gz). Untar this file into /usr/src. You'll get a folder, /usr/src/linux-2.4.20. cd into this directory, and run make menuconfig. Now you get a bunch of choices about your hardware - if there's something you don't understand, read the help. They're usually pretty short, and very helpful. For hardware drivers, you get to choose to compile them into the kernel (the "*") or use them as modules (the "M") or leave them out (" "). Modules can be added and removed, so they only take up memory when they're needed (sort of), also, they promote a little bit of flexibility, and on-the-fly parameter setting. I usually do some core things compiled in (MTRRs, APIC, USB-OHCI) but most hardware devices as modules (sound cards, ide-scsi, all my USB devices). When you're done configuring, you'll go to exit, and save your new configuration. Now do:

make dep && make bzImage && make modules && make modules_install

If you don't get any errors, you've successfully done the first step - you have a compiled kernel. Now you just have to boot it. What you're gonna do is something like

cp arch/i386/boot/bzImage /boot/mykernel-2.4.20
cp System.map /boot

You also might want to do
depmod -ae 2.4.20
to make sure your modules are set up before you boot

Now, you have to get your bootloader to boot your kernel. If it's lilo, you'll have to edit /etc/lilo.conf and add something like

image=/boot/mykernel-2.4.20
read-only

Follow the pattern of the other entries, if they specify a root, you should as well, if they don't, leave it out.

For GRUB, I don't know very much. My best advice would be a "man grub.conf" or looking at the GRUB HOWTO.

If your system uses initrd (you'll see initrd files in /boot) then you have to do a mkinitrd. I think all you should have to do is mkinitrd 2.4.20 /boot/myinitrd-2.4.20 and then specify it in LILO or GRUB, but I don't use initrd.

The kernel comes with these instructions too, under the "Documentation" directory, and in the README also. A self-compiled kernel will allow you to get rid of the kruft that packagers ship, and tune your system for what you want it to do.
  Forum: Technical Support · Post Preview: #2720 · Replies: 28 · Views: 14,931

andrewjenkins
Posted on: Jun 5 2003, 02:31 PM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


I'm not sure if this would fix the problem but MTRRs might not be enabled in your kernel. The easiest way to find out is to do "ls /proc/mtrr". If you don't get a "No Such File or Directory" then your kernel does support MTRRs. I didn't think MTRRs were a requirement for X, though. This is certainly bizarre.
  Forum: Technical Support · Post Preview: #2716 · Replies: 8 · Views: 3,822

andrewjenkins
Posted on: Jun 5 2003, 05:09 AM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


The NVIDIA drivers for Linux are excellent, IMHO. Try going to www.nvidia.com, and going to "download drivers" and click on Linux/IA32. They have instructions there - you probably just have to download two RPMs, install them (su, then rpm --install rpm_filename), and log out of X (GNOME/KDE), log back in. Unlike windows, you will most likely not even need to restart.

If you want to see what kind of a speedup you get, run glxgears before you install and after. I went from about 200FPS unaccelerated to 3700FPS accelerated with a similar card (GeForce 2 GTS)
  Forum: Technical Support · Post Preview: #2698 · Replies: 1 · Views: 1,738

andrewjenkins
Posted on: Jun 5 2003, 04:58 AM


Grub-er
**

Group: Members
Posts: 30
Joined: 5-June 03
Member No.: 930


It is legit to specify BusIDs in XF86Config. I have no idea if this would fix your problem, though. You could try

Section "Device"
Identifier "NVidia GeForce 2 GTS/Ti"
Driver "nvidia"
VideoRam 65536
BusID "PCI:0:20:0" #LOOK HERE
# Insert Clocks lines here if appropriate
EndSection

quoting XF86Config(5):

BusID "bus-id"
This specifies the bus location of the graphics card. For PCI/AGP cards, the bus-id string has the form PCI:bus:device:function (e.g., "PCI:1:0:0" might be appropriate for an AGP card). This field is usually optional in single-head configurations when using the primary graphics card. In multi-head configurations, or when using a secondary graphics card in a single-head configuration, this entry is mandatory. Its main purpose is to make an unambiguous connection between the device section and the hardware it is representing. This information can usually be found by running the X server with the -scanpci command line option.
  Forum: Technical Support · Post Preview: #2697 · Replies: 8 · Views: 3,822

2 Pages V   1 2 >

New Posts  New Replies
No New Posts  No New Replies
Hot topic  Hot Topic (New)
No new  Hot Topic (No New)
Poll  Poll (New)
No new votes  Poll (No New)
Closed  Locked Topic
Moved  Moved Topic
 

RSS Lo-Fi Version Time is now: 19th November 2017 - 12:37 PM